[Linux] Black artifacts when enabling accelerated layers

RESOLVED DUPLICATE of bug 630620

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 630620
7 years ago
7 years ago

People

(Reporter: drago01, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110930134335

Steps to reproduce:

Set layers.acceleration.force-enabled to true.


Actual results:

Serval artificats show up like:

1) Black Rectange when clicking on the fav icon
2) When doing autoscroll the cursor icon is surrouned by a black rectangle

It seems that what is supposed to be translucent (alpha 0) is rendered black.

glxinfo:
------------
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 285/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 285.05.09
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
-----------




Expected results:

No artifacts.

Updated

7 years ago
Blocks: 594876
Summary: Black artifacts when enabling accelerated layers → [Linux] Black artifacts when enabling accelerated layers

Updated

7 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
(Reporter)

Comment 1

7 years ago
Created attachment 566827 [details]
Screenshot showing the corruption

Comment 2

7 years ago
Ok, that one is already filed as bug 630346. Can you attach the other corruptions?
(Reporter)

Comment 3

7 years ago
(In reply to aceman from comment #2)
> Ok, that one is already filed as bug 630346. Can you attach the other
> corruptions?

Was rather hard to get as a screenshot so I created a screencast, which was too big too attach so I uploaded it here: http://193.200.113.196/apache2-default/videos/moz-bug.webm

Comment 4

7 years ago
That one is very similar to bug 630620. You could now make a screenshot out of that video and attach it to that bug. Your icon looks a bit better than that of the reporter there, but the cause is probably the same. I also see the problem (my icon is very similar to yours) so I have joined there.

Is there anything left here?
(Reporter)

Comment 5

7 years ago
(In reply to aceman from comment #4)
> That one is very similar to bug 630620. You could now make a screenshot out
> of that video and attach it to that bug. 

Yeah indeed ...

> Your icon looks a bit better than
> that of the reporter there, but the cause is probably the same. I also see
> the problem (my icon is very similar to yours) so I have joined there.

Yeah agreed.

> Is there anything left here?

No seems like this, bug 630346 and bug 630620 seems to have the same cause. Something is causing alpha to get rendered wrong.

So we probably could close this one as dupe but it is kind of a "double dupe".

Comment 6

7 years ago
Yes, there are many problems like this, maybe that's why layers are not yet enabled on linux by default.
I'll close this, but there is no "double dupe" option:)
You should have filed each issue as a separate bug.
No longer blocks: 594876
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630620
You need to log in before you can comment on or make changes to this bug.