Closed Bug 694388 Opened 8 years ago Closed 8 years ago

Timed-out clones should show up as Purple (infrastructure failure) on tinderbox / tbpl

Categories

(Release Engineering :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 693202

People

(Reporter: rcampbell, Unassigned)

Details

(Whiteboard: [hg])

Currently, timed-out or failing reclones appear to show up as a build failure (red) on TBPL. These should probably be purple as they're a failure in the infrastructure, not an actual build failure.
My worry about making this purple is that the failed clone will immediately be retried and that will cause the underlying issue with this problem to spread beyond a single build failing.

Basically if the issue is network saturation, then immediately retrying will just cause more network load and could impact builds other than this one.
I also want to dup this to 693202 as that is the proper solution - anything else is just ducttape over top of an bandaid solution
(In reply to Mike Taylor [:bear] from comment #2)
> I also want to dup this to 693202 as that is the proper solution - anything
> else is just ducttape over top of an bandaid solution

Rob: I feel your pain here, but I'm going to follow bear's suggestion and dupe this to the "make hg not suck" bug. 

During the hg outage(s) yesterday, we had some classes of builds that *were* retrying automatically on clone failures. They would simply start cloning again and made the problem even worse.
Status: NEW → RESOLVED
Closed: 8 years ago
OS: Mac OS X → All
Priority: -- → P3
Hardware: x86 → All
Resolution: --- → DUPLICATE
Whiteboard: [hg]
Duplicate of bug: 693202
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.