arm linux link failure: undefined reference to `halfmoon::Stubs::do_*

RESOLVED DUPLICATE of bug 750694

Status

Tamarin
Optimizing JIT
RESOLVED DUPLICATE of bug 750694
6 years ago
5 years ago

People

(Reporter: Trevor Baker, Unassigned)

Tracking

(Blocks: 1 bug)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 566934 [details]
build log

true "Compiling shell/PosixPartialPlatform"
true "Link shell/avmshell"
arm-none-linux-gnueabi-g++ -o shell/avmshell eval/eval-abc.o eval/eval-avmplus.o eval/eval-cogen.o eval/eval-cogen-expr.o eval/eval-cogen-stmt.o eval/eval-compile.o eval/eval-lex.o eval/eval-lex-xml.o eval/eval-parse.o eval/eval-parse-config.o eval/eval-parse-expr.o eval/eval-parse-stmt.o eval/eval-parse-xml.o eval/eval-unicode.o eval/eval-util.o shell/avmshell.o shell/ConsoleOutputStream.o shell/DebugCLI.o shell/DomainClass.o shell/FileClass.o shell/FileInputStream.o shell/ShellCore.o shell/SystemClass.o shell/swf.o shell/../extensions/JavaGlue.o shell/../extensions/SamplerScript.o shell/../extensions/Selftest.o shell/../extensions/SelftestInit.o shell/../extensions/SelftestExec.o shell/avmshellUnix.o shell/PosixFile.o shell/PosixPartialPlatform.o -L. -lzlib -lavmplus -lMMgc -lvmbase   -lzlib -lpthread --sysroot=/usr/local/arm-linux/debian5  
compiler version:
arm-none-linux-gnueabi-g++ (Sourcery G++ Lite 2009q1-203) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.

./libavmplus.a(hm-interpreter.o): In function `halfmoon::StubCaller::do_sf64(halfmoon::Interpreter*, halfmoon::BinaryStmt*)':
hm-interpreter.cpp:(.text._ZN8halfmoon10StubCaller7do_sf64EPNS_11InterpreterEPNS_10BinaryStmtE[halfmoon::StubCaller::do_sf64(halfmoon::Interpreter*, halfmoon::BinaryStmt*)]+0x3c): undefined reference to `halfmoon::Stubs::do_sf64(avmplus::MethodFrame*, double, int)'
./libavmplus.a(hm-interpreter.o): In function `halfmoon::StubCaller::do_sf32(halfmoon::Interpreter*, halfmoon::BinaryStmt*)':
hm-interpreter.cpp:(.text._ZN8halfmoon10StubCaller7do_sf32EPNS_11InterpreterEPNS_10BinaryStmtE[halfmoon::StubCaller::do_sf32(halfmoon::Interpreter*, halfmoon::BinaryStmt*)]+0x3c): undefined reference to `halfmoon::Stubs::do_sf32(avmplus::MethodFrame*, double, int)'
./libavmplus.a(hm-interpreter.o): In function `halfmoon::StubCaller::do_lf64(halfmoon::Interpreter*, halfmoon::UnaryStmt*)':
hm-interpreter.cpp:(.text._ZN8halfmoon10StubCaller7do_lf64EPNS_11InterpreterEPNS_9UnaryStmtE[halfmoon::StubCaller::do_lf64(halfmoon::Interpreter*, halfmoon::UnaryStmt*)]+0x44): undefined reference to `halfmoon::Stubs::do_lf64(avmplus::MethodFrame*, int)'
./libavmplus.a(hm-interpreter.o): In function `halfmoon::StubCaller::do_lf32(halfmoon::Interpreter*, halfmoon::UnaryStmt*)':
hm-interpreter.cpp:(.text._ZN8halfmoon10StubCaller7do_lf32EPNS_11InterpreterEPNS_9UnaryStmtE[halfmoon::StubCaller::do_lf32(halfmoon::Interpreter*, halfmoon::UnaryStmt*)]+0x44): undefined reference to `halfmoon::Stubs::do_lf32(avmplus::MethodFrame*, int)'
./libavmplus.a(hm-liremitter.o): In function `.LANCHOR1':
hm-liremitter.cpp:(.data+0x864): undefined reference to `halfmoon::Stubs::do_lf32(avmplus::MethodFrame*, int)'
hm-liremitter.cpp:(.data+0x870): undefined reference to `halfmoon::Stubs::do_lf64(avmplus::MethodFrame*, int)'
hm-liremitter.cpp:(.data+0x8a0): undefined reference to `halfmoon::Stubs::do_sf32(avmplus::MethodFrame*, double, int)'
hm-liremitter.cpp:(.data+0x8ac): undefined reference to `halfmoon::Stubs::do_sf64(avmplus::MethodFrame*, double, int)'
collect2: ld returned 1 exit status
make: *** [shell/avmshell] Error 1
build failed return value 2
(Reporter)

Updated

6 years ago
Blocks: 639475
(Reporter)

Comment 1

6 years ago
I accidentally pasted the compiler version in the middle of the build log above.
Here it is for clarify; all is contained in the build log attachment.

compiler version:
arm-none-linux-gnueabi-g++ (Sourcery G++ Lite 2009q1-203) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.

Comment 2

6 years ago
Ah yeah, the load/store opcodes for anything other than unaligned/little-endian need porting over.
(Reporter)

Comment 3

6 years ago
similar errors for mips linux
(Reporter)

Comment 4

6 years ago
Created attachment 567183 [details]
mips build log
(Reporter)

Comment 5

6 years ago
same problem in android

Comment 6

5 years ago
This is subsumed by the fixes in 750694
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750694
You need to log in before you can comment on or make changes to this bug.