Last Comment Bug 694450 - #winstripe-urlbar-back-button-mask is not vertically centered
: #winstripe-urlbar-back-button-mask is not vertically centered
Status: RESOLVED FIXED
: polish
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Windows 7
: -- trivial (vote)
: Firefox 10
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 682534
  Show dependency treegraph
 
Reported: 2011-10-13 16:29 PDT by Tss
Modified: 2011-10-26 00:28 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Identity box bleeding through back-button (51.55 KB, image/png)
2011-10-13 16:29 PDT, Tss
no flags Details
Screenshot with back-button invisible (9.26 KB, image/png)
2011-10-13 16:33 PDT, Tss
no flags Details
patch (1011 bytes, patch)
2011-10-14 08:42 PDT, Dão Gottwald [:dao]
shorlander: review+
Details | Diff | Splinter Review
White shadow over back button (102.91 KB, image/gif)
2011-10-15 15:18 PDT, Tss
no flags Details

Description Tss 2011-10-13 16:29:32 PDT
Created attachment 566968 [details]
Identity box bleeding through back-button

The "hole" of the mask is not vertically centered over the identity-box, causing the lower left corner of the identity-box to be visible through the back-button. This is easier to see using a dark Persona or a high contrast Windows theme, and quite visible when back-button is disabled.
Comment 1 Tss 2011-10-13 16:33:41 PDT
Created attachment 566969 [details]
Screenshot with back-button invisible
Comment 2 Peter Henkel [:Terepin] 2011-10-14 03:08:42 PDT
I filled Bug 694287 yesterday for this, plus more. This is duplicate.
Comment 3 Dão Gottwald [:dao] 2011-10-14 08:42:16 PDT
Created attachment 567106 [details] [diff] [review]
patch
Comment 4 Tss 2011-10-15 15:18:24 PDT
Created attachment 567302 [details]
White shadow over back button

The patch seems to fix the centering problem, but it makes a white shadow appear over the back button when when you pass the cursor over it.
Comment 5 Dão Gottwald [:dao] 2011-10-15 16:13:27 PDT
(In reply to Tss from comment #4)
> Created attachment 567302 [details]
> White shadow over back button
> 
> The patch seems to fix the centering problem, but it makes a white shadow
> appear over the back button when when you pass the cursor over it.

That wouldn't be caused by this patch, it's a different mask.
Comment 6 Stephen Horlander [:shorlander] 2011-10-18 13:48:16 PDT
Comment on attachment 567106 [details] [diff] [review]
patch

Review of attachment 567106 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Comment 8 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-10-19 03:22:55 PDT
https://hg.mozilla.org/mozilla-central/rev/7498aeb75412
Comment 9 Peter Henkel [:Terepin] 2011-10-26 00:28:43 PDT
Wasn't this suppose to be fixed?

Note You need to log in before you can comment on or make changes to this bug.