Adobe Flash Player Settings does not work in Fennec

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P4
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 affected, firefox12 affected, fennec11+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Adobe Flash Player 11 installs a second application, "Flash Player Settings" that lets one tweak local storage and set preferences for peer-assisted networking. Opening it in Fennec simply displays a "Download Flash" button.

Expected to see an 'activate plugin' container that loads their manager.

--
Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 Fennec/10.0a1

Samsung Galaxy SII (Android 2.3.4)
(Reporter)

Comment 1

6 years ago
Still reproducible.

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120104 Firefox/12.0a1 Fennec/12.0a1
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a2) Gecko/20120104 Firefox/11.0a2 Fennec/11.0a2
status-firefox11: --- → affected
status-firefox12: --- → affected
Component: General → General
Product: Fennec → Fennec Native
(Reporter)

Updated

6 years ago
No longer blocks: 687265

Comment 2

6 years ago
aaron, can you provide str?  We really couldnt figure out how to duplicate what you are seeing.
(Reporter)

Comment 3

6 years ago
Created attachment 586118 [details]
Nightly (01/05) - "Flash Player Settings"

Install the latest version of Flash from the Android market. It bundles an application, "Flash Player Settings". Tap that application and open it in Nightly/Aurora; which yields this.
Aaron, try setting enable plugins settings to yes in fennec settings, then restart fennec and then trying it out.  It should work.
(Reporter)

Comment 5

6 years ago
(In reply to Naoki Hirata :nhirata from comment #4)
> Aaron, try setting enable plugins settings to yes in fennec settings, then
> restart fennec and then trying it out.  It should work.

No difference. Same result in screenshot.

Comment 6

6 years ago
I can't reproduce this issue with plugins set to play automatically ("Enable plugins: Yes"). Testing on Atrix running 3.2.4 with Flash 11.

Comment 7

6 years ago
(In reply to Margaret Leibovic [:margaret] from comment #6)
> I can't reproduce this issue with plugins set to play automatically ("Enable
> plugins: Yes"). Testing on Atrix running 3.2.4 with Flash 11.

Oops, I mean 2.3.4.
(Reporter)

Comment 8

6 years ago
I don't know if this is related, but in Fennec, I dont get the redirect from settings.adobe.com to http://settings.adobe.com/flashplayer/mobile


curl -ILA "Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120109 Firefox/12.0a1 Fennec/12.0a1" http://settings.adobe.com/flashplayer/mobile
HTTP/1.0 302 Found
Location: https://settings.adobe.com/flashplayer/mobile
Server: BigIP
Connection: Keep-Alive
Content-Length: 0

HTTP/1.1 301 Moved Permanently
Date: Mon, 09 Jan 2012 15:06:33 GMT
Server: Apache
Location: http://settings.adobe.com/flashplayer/mobile/
Cache-Control: max-age=900
Expires: Mon, 09 Jan 2012 15:21:33 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: close

HTTP/1.1 200 OK
Date: Mon, 09 Jan 2012 15:06:33 GMT
Server: Apache
Accept-Ranges: bytes
Cache-Control: max-age=900
Expires: Mon, 09 Jan 2012 15:21:33 GMT
X-Frame-Options: DENY
Content-Length: 1630
Content-Type: text/html; charset=UTF-8
Connection: close

X-Frame-Options: DENY?

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120109 Firefox/12.0a1 Fennec/12.0a1

Updated

6 years ago
Priority: -- → P4
tracking-fennec: --- → 11+
Aaron, if you use phony (http://limpet.net/mbrubeck/temp/phony.xpi) to change the UA String to the default browser, do things work?
(Reporter)

Comment 10

6 years ago
Says downloading but doesn't install. Can't find it in Add-ons Manager. (Nightly 01/09).
I just realized something; I thought flash only works for 2.3 and lower, not for ICS or Honeycomb?
(Reporter)

Comment 12

6 years ago
(In reply to Naoki Hirata :nhirata from comment #11)
> I just realized something; I thought flash only works for 2.3 and lower, not
> for ICS or Honeycomb?

Yeah you're right, shi-. My fault, ignore comment #1, I was recently testing on 4.0.3.

Re-tested just now on 2.3, Flash 11, 'Enable Plugins: Yes', and opened in Nightly and it works.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.