Login failure Apple iCloud me.com

RESOLVED INVALID

Status

MailNews Core
Networking
--
major
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: Daniel, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(firefox8+, firefox9+ unaffected)

Details

(Whiteboard: [has protocol logs], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Want to add the new new Apple iCloud Account to Thunderbird. Email address like xxxx@me.com


Actual results:

I get an Login failure. Username or password are incorrect. On other clients, for example Mail.app on OSX Lion or Outlook 2011 the Account is working.
My configuration:
incoming mail server: imap.mail.me.com (SSL 993) or p01-imap.mail.me.com
Username: xxxx(without @me.com) and xxxx@me.com

outgoing mail server: smtp.mail.me.com (Port 587) or p01-smtp.mail.me.com
Username: xxxx(without @me.com) and xxxx@me.com

Authentication: "password normal"

So I have tested both, the config of Mail.app and the config that is discribed here:
http://support.apple.com/kb/HT4864

Unfortunately nothing works and I get the same error. The old MobileMe Account is working but iCloud not...

With ping and telnet I tested the access to the mail servers.


Expected results:

An successfully login to my imap iCloud account
Do you already tried different authentication methods (insecurely or encrypted) and the connection security settings ?
(Reporter)

Comment 2

7 years ago
yes I also tried "password normal" and "encrypted password" for both servers (imap.mail.me.com and p01-imap.mail.me.com)
>Username: xxxx(without @me.com) and xxxx@me.com

Does this means you tried both ?

Comment 4

7 years ago
Can confirm this problem. I'm a "old" me.com user and today Thunderbird refused login to my moved me.com account. I've try'd already the settings from Apple, but still no combination works for me.
(Reporter)

Comment 5

7 years ago
Yes I tried both username combinations.
(Reporter)

Updated

7 years ago
Severity: normal → major
Hardware: x86 → x86_64
Can we get an imap log as described at https://wiki.mozilla.org/MailNews:Logging maybe we'll see more in these ?

(In reply to Daniel from comment #5)
> Yes I tried both username combinations.

Hum I asked because our https://live.mozillamessaging.com/autoconfig/v1.1/me.com isn't completely in synch with https://support.apple.com/kb/HT4864. Ben shall I file a followup bug for that ?

Hoping we'll see more in the logs from imap.
Component: General → Networking
Product: Thunderbird → MailNews Core
QA Contact: general → networking
Hardware: x86_64 → All
tracking-firefox8: --- → ?
tracking-firefox9: --- → ?
(Reporter)

Comment 7

7 years ago
Created attachment 567423 [details]
imap logfile for iCloud me.com
Comment on attachment 567423 [details]
imap logfile for iCloud me.com

It seems we can't parse the answer given by the server.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [has protocol logs]

Comment 9

7 years ago
No, the server can't parse what we send, i.e. server bug.

We send: 2 authenticate plain
Server responds: BAD Parse Error

Just guessing: Maybe the server expects a one-liner AUTH PLAIN directly with credentials, although both forms (credentials on same line or followup line) are allowed.

We should escalate this to Apple.

Updated

7 years ago
Assignee: nobody → dbienvenu
(Assignee)

Comment 10

7 years ago
I'll try to setup a iCloud account and see if I can figure it out.
Status: NEW → ASSIGNED
am i missing something? iCloud email like mobileme email works fine for me. I tested on Friday and it works:
http://getsatisfaction.com/mozilla_messaging/topics/icloud#reply_6900214

perhaps this only affects new iCloud users? (I am an old MobileMe user)

Comment 12

7 years ago
(In reply to Roland Tanglao :rolandtanglao from comment #11)
> am i missing something? iCloud email like mobileme email works fine for me.
> I tested on Friday and it works:
> http://getsatisfaction.com/mozilla_messaging/topics/icloud#reply_6900214
> 
> perhaps this only affects new iCloud users? (I am an old MobileMe user)

Problem was today morning that (as a old MobileMe user) the mail.me.com server reply was "www.me.com/move" as a server message every time you check mails (Popup in Thunderbird). So i can confirm that the annoying server reply is gone now. With the old (!) settings, e.g. mail.me.com and smtp.me.com and the default settings from old MobileMe you can send / receive mails again. The new settings from Apple's iCloud instructions are still a NoGo.

Comment 13

7 years ago
shadesh, do I understand you correctly that this was indeed a server error, and they fixed it meanwhile, so this bug is gone?

Also, you're saying that the official instructions are wrong and not working, but our config (used in Thunderbird's automatic setup) is working fine?

So, nothing to be done here, just Apple being chaotic? Can we close this?
(Reporter)

Comment 14

7 years ago
nope only the old mobileme accounts are working again(mail.me.com,smtp.me.com). iCloud doesn´t work at all...

Comment 15

7 years ago
Maybe this "bug" is fixed now on Apple side.

Yes, old settings fine, new settings bad.

Maybe Apple will disable the old settings for MobileMe soon and then you have to use the new settings for iCloud which are still a NoGo in Thunderbird.

But for now it's fine, at least for me. Whats up with the other people here? Works with the "old" settings?
(Reporter)

Comment 16

7 years ago
it seems that old mobileme users that migrate to icloud can use the old settings?! and these ones are still working, but new icloud users can´t do it, so for them imap with icloud is not working...

Comment 17

7 years ago
> new settings for iCloud which are still a NoGo in Thunderbird.

Ah, thanks. And the log and my comment 9 indeed applies to the new imap.mail.me.com , not to the old mail.me.com .
(Reporter)

Comment 18

7 years ago
just a bit OT: the icloud calendars don´t work ether in TB/Lightning. is there a way to log caldav access as in comment 6 for imap?

Comment 19

7 years ago
Daniel, please file a new bug for that, or ask on the newsgroups.
(Assignee)

Comment 20

7 years ago
the imap.mail.me.com server definitely rejects AUTHENTICATE "PLAIN" - I fiddled around with sending the info all on the same line and using string literals, but the embedded nulls caused an issue. I'm not sure how standard our base64 encoding of the username and password string is, but we're not getting that far with the iCloud server. I'll see why (and if) it works with Outlook, if I can get Outlook protocol logging to work.
(Assignee)

Comment 21

7 years ago
Outlook definitely works, but it doesn't log anything about the authentication process, so that wasn't too helpful. And since it uses SSL, packet sniffing won't be helpful.
(Assignee)

Comment 22

7 years ago
OK, if I make Thunderbird ignore the AUTH PLAIN capability, we can login to a me.com server. So we're not trying other simpler auth mechanisms when the server advertises AUTH PLAIN but fails when we try it. Since AUTH PLAIN is nearly as insecure as could be, there's no reason not to fall back to plain old login.
(Assignee)

Comment 23

7 years ago
It's also possible that we don't like the BAD response during AUTH and that breaks fallback to other auth mechanisms.
(Assignee)

Comment 24

7 years ago
ugh, it looks like we are falling back to the other auth mechanism, but the iCloud server gets into a state where it doesn't like our plain login command. So the only way it would work is if we didn't try AUTH PLAIN in the first place...

Comment 25

7 years ago
bienvenu, iCloud is just being created. I think that's just a bug on their side. Can we reach them? I'm always for fixing rather than working around.

(The embedded nulls are per spec.)

Comment 26

7 years ago
(fixing their server would also help our users of existing and older versions)
(Assignee)

Comment 27

7 years ago
(In reply to Ben Bucksch (:BenB) from comment #26)
> (fixing their server would also help our users of existing and older
> versions)

I understand that the embedded nuls are per spec, but our code makes it a little hard to send embedded nuls. But I worked around it, and the server still rejected the auth. I reached out to a friend on the iCloud team; we'll see what happens.

Comment 28

7 years ago
Any news here ?
By the way, imap icloud account works with the unix tool imapcopy.

Comment 29

7 years ago
It's been a week, David. Anything from iCloud yet?
(Assignee)

Comment 30

7 years ago
My understanding is that an iCloud fix is being rolled out though I don't know how long it will be before it is fully deployed.

Comment 31

7 years ago
---------------------------------[ Triage Comment ]---------------------------------

We'll track this for Firefox 8/9 until it is clear we don't need product changes.

Also, we happen to know the EPM in charge of the iCloud launch, we'll escalate ;-)

Adding akeybl to escalate with Apple in case I don't get around to it.
tracking-firefox8: ? → +
tracking-firefox9: ? → +

Comment 32

7 years ago
I just tried a long-form server name (p02-imap.mail.me.com) in the latest Thunderbird 8 beta and it works now, for me.
(Assignee)

Comment 33

7 years ago
yes, thx, it's working for me too. Apparently the multi-line approach didn't work earlier but that's been fixed on the servers.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 34

7 years ago
I spoke too soon. I can receive and send mail, but I can't do anything involving folders. Sent mail doesn't get saved to Sent, and deleted mail doesn't get sent to Trash.
(Assignee)

Comment 35

7 years ago
We don't recognize Sent Items as the Sent folder (presumably, they don't support xlist), but we do create our own Sent folder and put sent mail in it. Deleting to trash works fine for me.
(Assignee)

Comment 36

7 years ago
and if you tell Thunderbird to use Sent Items as the send folder in account settings, it works fine.

Comment 37

7 years ago
receiviing mails over the imap server works now
but for some reason a can not send mails: Login to server smtp.mail.me.com failed.

my config is:
server: smtp.mail.me.com
port: 587
security: STARTTLS

cheers
andre
(Assignee)

Comment 38

7 years ago
smtp.me.com, with those same settings, works for me.

Comment 39

7 years ago
I'm using p02-smtp.mail.me.com and it's working for me.

The folders thing has also mostly cleared up for me but I had to delete and recreate the account in Thunderbird to get to this point. There's still some room for improvement but at least now I can use it.

Comment 40

7 years ago
andre, ak4mc, could you each try the other's setting, i.e. ak4mc, can you try smtp.mail.me.com, and andre, can you try p02-smtp.mail.me.com?

Maybe it's their load balancer that's failing.

Comment 41

7 years ago
Both worked fine for me just now, as did smtp.me.com

I'll leave it on that one unless it gives me trouble.

Comment 42

7 years ago
smtp.me.com, smtp.mail.me.com, p02-smtp.mail.me.com
none of that 3 servers is working for me using port 587 and security method STARTTLS
andre

Comment 43

7 years ago
I forget where now, but I've seen it also suggested that if p02 doesn't work, try p01 or p03.

Andre, what IMAP server are you using to receive mail?

Comment 44

7 years ago
the IMAP server i use is imap.mail.me.com, port 993, security SSL/TLS
p01 and p03 are not working dor me
andre

Comment 45

7 years ago
I'm stumped.

Comment 46

7 years ago
very weired
i changed the password for my apple id, now it works, i can receive and send mails
smtp settings:
server: smtp.me.com
port: 587
security: STARTTLS

Comment 47

7 years ago
My (previously expired) mobileme account was transitioned to iCloud.

1)  Password change

At iCloud launch, my iCloud account would not authenticate against apple's IMAP servers, following Apple's recommendations at http://support.apple.com/kb/HT4864.  Mac OS X 10.6.8, TB 7.0.1 Release.  I configured my account through the Thunderbird new account wizard and manually edited the IMAP URL from mail.me.com to match the advice in the apple documentation HT4864.  Thunderbird still defaults to pointing @me.com users at mail.me.com as the imap server.

I held out for a while, following this bug.  I did not use about:config to downgrade my authentication settings.

On another Mac, I tried Mac OS X 10.7.2, TB 8.x Beta.  It still failed to authenticate.

My username and password worked fine using Max OS X 10.7.2 Mail.app.

So I took the advice in this thread, changed my iCloud password and it worked in both TB 7.0.1 and TB 8.x Beta.

So it is not just new accounts that don't authenticate.  But yes, changing your password does work and triggers an authentication synchronisation somewhere in Cupertino which seems to free up TB to authenticate.

2)  Apple's Load Balancer.

It worked the first time using imap.mail.me.com as per Apple's advice.  However, I was crazy enough to close Thunderbird and re-open.  Upon next restart, TB would attempt to authenticate three times to finally fail.  I configured an account in Mail.app and noted that Mail.app under Lion 10.7.2 points direct at p01-imap.mail.me.com rather than the imap.mail.me.com farm.  I followed the same in TB and it works across reboots using p01-imap.

So if anyone is still having icloud login issues under Thunderbird/Mac, first try another imap client, if that works change your password and finally try different imap servers p01-imap, p02-imap, p03-imap, p99-imap etc rather than just imap.mail.me.com.

I have not tried SMTP as I use a different service for sending mail.

Updated

6 years ago
status-firefox9: --- → unaffected

Comment 48

3 years ago
Hi. I just resolved my issues with iCloud in Thunderbird. I wrote it, but I still doesn't translatet it to English. I put it now in Spanish. You can translate or wait that I got it translated by myself. Sorry for the inconvenience (my English in a little bad  XD)

–––––––– In Spanish ––––––––

La configuración de una cuenta de correo de iCloud no es compatible con la configuración de Thunderbird. Este utiliza un mapa de carpetas diferente al de iCloud, por lo que hay que hacer algunos pequeños cambios.

Antes de nada, si se ha intentado instalar con anterioridad una cuenta de icloud con resultados insactisfactorios, es recomendable antes eliminar la cuenta de Thunderbird, y eliminar cualquier archivo de dicha cuenta en:

{user}/Library/Thunderbird/Profiles/xxxxxxxxxxx/ImapMail/

imap.mail.me.com   (carpeta)
imap.mail.me.com.msf

1. Configurar la cuenta de iCloud en Thunderbird.

Es un poco más complicado de lo que debería. Esto no es error de Apple. Ellos funcionan bien con su propio programa de correo, y no van a cambiar su propia configuración por un programa de terceros.
Por ello es algo que debería corregir Mozilla para próximas versiones de Thunderbird.

– nueva cuenta de correo
– nombre, email y contraseña
...busca configuración: su proveedor de correo...
...base de datos ISP...
...probando nombres habituales de servidor...
…por defecto Thunderbird “propone” una configuración errónea. Dice así:

Nombre del servidor – Puerto – SSL – Identificación
Entrada IMAP .icloud.com – Auto – Autodetectar – Autodetectar
Saliente: SMTP .icloud.com – Auto – Autodetectar – Autodetectar
Nombre de usuario: Entrante: {usuario} (sin @icloud.com – Saliente: {usuario} sin @icloud.com

.icloud.com NO ES VÁLIDO. Debe poner: imap.mail.me.com (incluyendo imap.)
Puerto: 993 – SSL: SSL/TLS – Identificación: Contraseña normal
SMTP: smtp.mail.me.com:587  (al poner así desaparecen las opciones siguientes)
Identificación: Contraseña normal tanto en entrante como en saliente.
Nombres, dejarlos SIN @icloud.com

Aceptar.

2. Carpetas

Automáticamente Thunderbird crea los archivos en la ruta anteriormente citada de donde hemos borrado cualquier rastro de configuración anterior, con únicamente 4 archivos:

Drafts.msf
INBOX.msf
Sent.msf
Templates.msf

En la web de iCloud: https://www.icloud.com/#mail
depositamos un correo cualquiera en cada una de las carpetas: Bandeja de entrada, Borradores, Enviados, Archivados, Papelera y Correo no deseado.

Para que funcione, tiene que haber al menos un archivo dentro de cada carpeta, incluso la de borradores (Drafts), podemos mover cualquier otro correo, y si es “virgen”, pordemos crear varios borradores, guardarlos y moverlos a cada una de las demás carpetas “básicas”, las que tiene un icono propio.


Para que Thunderbird lea cualquier cambio es necesario dar a Aceptar en la ventana de Configuración, y si al volver a entrar aun no lo ha leído, salir de Thunderbird y volver a abrirlo. Al hacerlo el programa lee los archivos nuevamente desde el servidor de iCloud.

Thunderbird, al empezar con una cuenta, crea una estructura de carpetas. Estas no coinciden con las de iCloud.

Thunderbird  /  iCloud (ok)
Archives  /  Archive
Drafts  /  Drafts
INBOX  /  Mailbox
Junk  / Junk
Sent  /  Sent Messages
Templates  /  –no hay–
Trash  /  Deleted Messages

Si no cambiamos previamente la RAÍZ de IMAP desde Thundebird, puede que se muestren otras carpetas que se hubieran creado previamente y que no se han terminado de eliminar del todo, bien por caché o por cualquier otro motivo.

El problema de Thunderbird es que si seleccionamos que él seleccione las carpetas “por defecto”, él va CREAR sus propias carpetas, con sus nombres, no con los que iCloud reconoce como buenos. Eso hace que, por ejemplo, aparezca un “Thash” en la web de iCloud, y un “Deleted Messages” en Thunderbird (así como cualquier otra correspondiente). Como no podemos CREAR las carpetas correctas porque al intentarlo iCloud nos dice que YA EXISTEN, vamos a hacerlas dentro de OTRA CARPETA:

Por ejemplo, creamos una carpeta a la que llamamos hola (o cualquier otro). Dentro creamos las siguientes carpetas: Archive, Drafts, Sent Messages, Deleted Messages

En Thunderbird, en Configuración > Configuración del servidor > Avanzadas…
Para la cuenta “iCloud” directorio del servidor IMAP: hola

(recordad salir de Thunderbird sin no se muestran los cambios instantáneamente)

Por si acaso quitamos momentaneamente la opción: Mostrar sólo las carpetas suscritas
Al hacer esto, aparecen (si no estaban ya), dentro de la carpeta Mailbox (la raíz de iCloud), todas las carpetas “por defecto” de iCloud. En mi caso, en castellano: . (punto), .. (punto punto), Archivados, Borradores, Deleted Messages, Enviados y No deseado
(es curioso que algunas estén en español, pero la papelera aparezca en inglés)

Podemos comprobar, cambiando correos desde la web en iCloud, como van apareciendo los diferentes mensajes en cada carpeta, para ver cómo se comporta.

Ya cambiada la RAÍZ de IMAP y creadas la carpetas con los nombres correctos, procedemos a ENLAZARLOS:

1) En Configuración del servidor > Configuración del servidor > Cuando borre un mensaje: Moverlo a esta carpeta: Deleted Messages en icloud.

2) En conf. > Copias y carpetas, vamos una por una seleccionando las carpetas con los nomnbres correctos: 
– Al enviar mensajes, automáticamente: Poner en copia en: Otro: Sent Messages en iCloud
– Archivos de mensajes, Guardar archivos de mensajes en: Otro: Archive
– Borradores y plantilla, borradores, esta al ser la única que coincide, usar la por defecto.
– Plantillas, al no haber de eso en iCloud, crear una para dicha función, tanto en la RAÍZ de iCloud, como dentro de la carpeta “hola” que hemos creado provisionalmente, con el nombre Templates.

3) En Correo no deseado > Destino y retención > Mover mensajes de correo no deseado a: Carpeta de “correo no deseado” en: iCloud. Aquí ambas se llaman igual: Junk, por lo que no hay problema.

Aceptar. Salir y volver a entrar en Thunderbird. Si han quedado carpetas sueltas no asignadas a algo, borrarlas o cambiarlas a otro sitio fuera de “hola”. Ya veremos luego dónde ubicarlas.

Al volver a Configuración, solo deberían aparecer las carpetas con su icono:
– Bandeja de entrada  (esta “carpeta” no la vemos porque es la “raíz”)
– Borradores  (aunque realmente la carpeta se llama Drafts)
– Plantillas  (lo mismo, pero la carpeta se llama Templates)
– Sent Messages  (en su nombre en inglés)
– Archive  (idem)
– Deleted Messages  (idem)

Pues bien, si ya está todo “limpio”, vamos a volver a cambiar la RAÍZ de IMAP a la RAíZ de iCloud.
Para ello volvemos a Conf. > Config. del servidor > Avanzadas…
y quitamos la palabra “hola” de donde lo habíamos puesto. ACEPTAR. ACEPTAR. SALIR.
Volver a entrar en Thunderbird.

Deberían desaparecer las carpetas anteriormente creadas, o mejor dicho, ahora aparece una carpeta llamada “hola”, dentro de la cual están todas aquellas.

Podría ser que apareciese una nueva carpeta llamada Notes. Esto es debido a que si tenemos desactivada la opción de sincronizar las notas en iCloud (tanto en el ordenador como en un móvil), iCloud convierte las notas en una carpeta visible en el correo, aunque no desde Apple Mail ni desde la web de iCloud. Para hacerla desaparecer, activamos la opción de “solo ver carpetas suscritas” y no suscribirse a esta. Pero esto trae otros problemas así que de momento ahí se queda.



El mayor problema está en la carpeta Mailbox, que desde Thunderbird no se puede configurar, siendo siempre INBOX, y aparece una carpeta Mailbox en cursiva con dos subcarpetas dentro, con un punto y otra con dos puntos (MS-DOS, directorio actual y directorio superior). Estos están protegidos y no se pueden eliminar.

Desde Thunderbird se puede cambiar la raíz de carpetas dentro de la cuenta de correo, pero esto lo que hace es crear esa carpeta en el directorio raíz de la cuenta de correo y sus respectivas subcarpetas, pero no en las correspondientes carpetas de iCloud.

Tampoco se pueden crear las carpetas adecuadas con el nombre que queremos en la raíz de iCloud (desde la web), porque YA existen.

La solución para enlazar correctamente las carpetas en su nombre correcto, para evitar que cree carpetas “duplicadas” (con la misma función pero con nombres diferentes), es asignar a cada categoría su correspondiente carpeta, con el nombre correcto. Eso se hace desde Configuración de cuenta > Copias y carpetas.

Pero cuando vamos a seleccionar la carpeta que queremos en la cuenta recién configurada, vemos que no aparece entre las que nos deja elegir. Eso es porque no la ha “descargado”, por no encontrar ningún “cambio” dentro de ella. Además hay que verificar que estén subscritas (se puede ver si lo está seleccionando con el botón derecho en el icono de la cuenta iCloud > Suscripciones. Hay que marcar las que quieramos que nos aparezcan, las que hemos tenido que crear previamente desde la web de iCloud.
You need to log in before you can comment on or make changes to this bug.