Last Comment Bug 694797 - Cairo fails to build with VC11 because it tries to #define inline, which is a keyword in C++
: Cairo fails to build with VC11 because it tries to #define inline, which is a...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: :Ehsan Akhgari (away Aug 1-5)
:
Mentors:
: 687229 (view as bug list)
Depends on:
Blocks: VC11
  Show dependency treegraph
 
Reported: 2011-10-15 16:12 PDT by :Ehsan Akhgari (away Aug 1-5)
Modified: 2011-10-17 11:15 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (2.14 KB, patch)
2011-10-15 16:20 PDT, :Ehsan Akhgari (away Aug 1-5)
jmuizelaar: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari (away Aug 1-5) 2011-10-15 16:12:05 PDT
VC11's xkeycheck.h catches this with an #error.
Comment 1 :Ehsan Akhgari (away Aug 1-5) 2011-10-15 16:20:42 PDT
Created attachment 567307 [details] [diff] [review]
Patch (v1)
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-10-15 17:06:00 PDT
*** Bug 687229 has been marked as a duplicate of this bug. ***
Comment 3 :Ehsan Akhgari (away Aug 1-5) 2011-10-17 07:43:15 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a6c0f080eaab
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2011-10-17 11:15:51 PDT
https://hg.mozilla.org/mozilla-central/rev/a6c0f080eaab

Note You need to log in before you can comment on or make changes to this bug.