Last Comment Bug 694863 - SVG rendering is clipped when it should be not
: SVG rendering is clipped when it should be not
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 668163
Blocks: 611099
  Show dependency treegraph
 
Reported: 2011-10-16 11:17 PDT by Marek Raida
Modified: 2012-01-14 07:26 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marek Raida 2011-10-16 11:17:46 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111016 Firefox/10.0a1
Build ID: 20111016031010

Steps to reproduce:

Open http://themaninblue.com/experiment/AnimationBenchmark/svg/


Actual results:

Particles benchmark - dots are rendered only in the top right box of approx 250*250 pixels, the rest of the window stays white.


Expected results:

Colorful dots should have been moving around the whole screen.
Like in canvas case (http://themaninblue.com/experiment/AnimationBenchmark/canvas/)
It is not HW acceleration/driver related and happens also with HW rendering turned off.
I'm using the latest nightly build (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111016 Firefox/10.0a1)
Comment 1 Alice0775 White 2011-10-16 11:37:15 PDT
regression  window:
Last good m-c nightly: 2011-06-12
First bad m-c nightly: 2011-06-13
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e37011790a8a&tochange=bbbc80a2bd8c

in local build,
build from 3af9fed4e33a : fails
build from 58fe3ede72f8 : fails
build from c07445f34e92 : works
build from db0bcc6ab526 : works
Triggered by 
58fe3ede72f8	L. David Baron — Remove notion of percentage intrinsic size: remove the single case that (incorrectly) sets percentage intrinsic sizes, and fix all of the tests that depend on our old incorrect behavior. (Bug 611099) r=dholbert Needed to help CSS 2.1 meet Proposed Recommendation entrance criteria.

And this will be fixed by Bug 668163

*** This bug has been marked as a duplicate of bug 668163 ***
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-10-16 12:45:25 PDT
Yep.  What we're doing right now is what the spec currently says to do...
Comment 3 Robert Longson 2012-01-14 07:26:36 PST
Fixed by bug 668163

Note You need to log in before you can comment on or make changes to this bug.