Last Comment Bug 694865 - VC11 cannot compile the IE profile migration code because pstore.h no longer ships with the SDK
: VC11 cannot compile the IE profile migration code because pstore.h no longer ...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: x86 Windows 8
: -- normal (vote)
: Firefox 10
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on:
Blocks: VC11 698433
  Show dependency treegraph
 
Reported: 2011-10-16 12:01 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2011-10-31 07:43 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (6.26 KB, patch)
2011-10-16 12:02 PDT, :Ehsan Akhgari (busy, don't ask for review please)
netzen: review+
Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2011-10-16 12:01:33 PDT
Therefore, we need to define the stuff that we use from that header ourselves.  This is the header from another SDK installation: https://gist.github.com/1291028
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-16 12:02:33 PDT
Created attachment 567347 [details] [diff] [review]
Patch (v1)
Comment 2 Brian R. Bondy [:bbondy] 2011-10-24 13:28:12 PDT
Comment on attachment 567347 [details] [diff] [review]
Patch (v1)

Review of attachment 567347 [details] [diff] [review]:
-----------------------------------------------------------------

- Verified that I get the problem building with VC2011 on Win7 and Windows SDK v7.1 and that the patch fixes it.
  - The 3 patches procduce a successful build and firefox.exe launches.
- Verified that it doesn't cause a problem with VS2010 w/ 7.1
- Did not try other supported setups but I think it will be OK.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-24 14:04:53 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/73e262cd7ee8
Comment 4 Marco Bonardo [::mak] 2011-10-25 04:59:28 PDT
https://hg.mozilla.org/mozilla-central/rev/73e262cd7ee8
Comment 5 Jim Mathies [:jimm] 2011-10-31 07:02:33 PDT
A decision was made a while back not to do this anymore, since the headers are copyrighted by microsoft. I think we should just ifdef out the code that makes use of this in cases where we are building with vc 11.
Comment 6 Gervase Markham [:gerv] 2011-10-31 07:18:47 PDT
:jim: would that mean that we would no longer support profile migration from IE?

Gerv
Comment 7 Jim Mathies [:jimm] 2011-10-31 07:39:30 PDT
(In reply to Gervase Markham [:gerv] from comment #6)
> :jim: would that mean that we would no longer support profile migration from
> IE?
> 
> Gerv

Looks like it's tied into migrating sign-on information (form data cache) for specific web sites. I wonder though if newer version of ie are even using this. I'll file a bug on investigating whether this code is still doing anything useful.

Note You need to log in before you can comment on or make changes to this bug.