www.scribd.com overlays text in PNG image with little black squares

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Artiom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 567350 [details]
screen.PNG

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110926211223

Steps to reproduce:

Look at this page
http://www.scribd.com/doc/67263756?secret_password=f7fjd0cmu5b3oee3u9n
And compare the fonts on windows and linux


Actual results:

With Firefox on windows the text is ugly and not readable


Expected results:

Like on linux - readable text.
That may be a Windows, problem, more than a Firefox one. I'm having similar problems with a much normal font like the ones of the Free font family, since Windows sucks at rendering anti-aliased fonts. Have you tried to open that page with other browsers on Windows (IE for example is the one that renders the Free fonts the best)? And on which Windows version? Because for example XP sucks more than 7 with "not plain" fonts.

Comment 2

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111014 Firefox/10.0a1

This is a PNG image with text. The Image itself is fine.
http://htmlimg1.scribdassets.com/9c4k17c6f415tcq5/images/1-c72f5ae5bd.png

But there are black squares placed over the letters (onload?).
I assume there is a bug in scribd.com or that's intended for whatever reason (money?).

Firebug shows of hacky z-indexed code with class-names like
"ie-fix", "ff0", "ff1", "ff2", "ff4".
Works with minor glitches in Opera and Google Chrome.

You should report this to  scribd.com  also.
Component: General → General
OS: Linux → Windows XP
Product: Firefox → Core
QA Contact: general → general
Hardware: x86_64 → x86
Summary: Bad font rendering in windows → www.scribd.com overlays text in PNG image with little black squares
Version: 7 Branch → Trunk

Comment 3

7 years ago
> Works with minor glitches in Opera and Google Chrome
and IE8

Comment 4

7 years ago
It works as expected, if I set  "general.useragent.override" to "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.220 Safari/535.1".

So, I think this is the Tech Evangelism.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 5

7 years ago
Artiom, please report this to scribd.com and refer to this bug report.
This is most likely not a bug in Gecko/Firefox.
(Reporter)

Comment 6

7 years ago
I submitted this bug to scribd but the ticket was deleted without any comments.
I submit it again
http://support.scribd.com/requests/140750

Comment 7

4 years ago
Is it still an issue?
Assignee: english-us → nobody
Component: English US → Desktop
Flags: needinfo?(ar.molchanov)
Given URL works fine for me in Firefox on Windows
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 9

4 years ago
> Given URL works fine for me in Firefox on Windows

No, I see this bug (exactly what attachment 567350 [details] shows)
here: 
Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0
and here:
Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta)
and here:
Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0 (Aurora)

but not here:
Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0 (Nightly)

I still think it's strange (malicious?) browser sniffing (see comment 2 and comment 4)
They add small black squares depending on UA.

Hallvord, weren't you the one who investigated those issues at Opera?
Status: RESOLVED → REOPENED
Flags: needinfo?(ar.molchanov)
Resolution: WORKSFORME → ---
> I still think it's strange (malicious?) browser sniffing (see comment 2 and
> comment 4)
> They add small black squares depending on UA.

Hm.. UA or some feature they think is or isn't present? Did you try to use Fx 32 with the Fx 35 UA string?

> Hallvord, weren't you the one who investigated those issues at Opera?

I did indeed look at some Scribd issues (and lots of others) at Opera ;)
Status: REOPENED → NEW

Comment 11

4 years ago
> Did you try to use Fx 32 with the Fx 35 UA string?

I didn't, but obviously I should have, because the result is:
My Fx 32 with Fx 35 UA override is buggy.
> My Fx 32 with Fx 35 UA override is buggy.

Hm.. so it doesn't sound quite like a UA sniffing issue. It might be a Firefox bug that's fixed in 35. It might also be an issue with your settings and config (if you tested 35 with a separate profile).

It's annoying that I can't reproduce.. I guess we will just leave this open and see if you can close it as worksforme in a few months when 35 ships.

Comment 13

4 years ago
(In reply to Hallvord R. M. Steen from comment #12)
> > My Fx 32 with Fx 35 UA override is buggy.
> 
> Hm.. so it doesn't sound quite like a UA sniffing issue. It might be a
> Firefox bug that's fixed in 35. It might also be an issue with your settings
> and config (if you tested 35 with a separate profile).


In Firefox32 on windowsXP Sp1, Following UA spoofing helps. So this is the site problem.
Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
I do not have any issues with Firefox Nightly 51.0a1 (2016-08-28)
They might have fixed it. 

Closing as worksforme.

Note that the full markup is a bit silly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.