Table background image tiles page background image.

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: webmas7, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] pollmann, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
1. Logo appears as a dot in upper left. img src has no defined size and is also
a link. Above green circle area.

2. Skinny transparent images are not transparent (also www.cnet.com)

3. Two (input type="image") do not show up on page nearby the two form objects

4. Images coming from full URL ie http://www.cedarnet.org/graphics3/logo.gif do
not seem to load. Probably THE CAUSE for 1, 2, 3

5. Reloading the page or going forward then returning to page results in layout
errors.

Updated

19 years ago
Assignee: rickg → karnaze

Comment 1

19 years ago
Chris -- these appear to input type=image problems. Please take a look.
One other note: the images he says never loaded, showed up fine for me, but they
did take a while.

Updated

19 years ago
Assignee: karnaze → pollmann

Comment 2

19 years ago
I'm not seeing these problems on WinNT. I am seeing that some of the images get
clipped when they are scrolled. Reassigning to Eric.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Reporter)

Comment 3

19 years ago
Testing on newer builds shows that the logo still appears as a dot (it is <img
src> with no defined size in HTML) , but other images now seem to load fine.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
Summary: Multiple problems → Image with no specified size shows up as a dot

Comment 4

19 years ago
(I'm assuming you mean the image of a cityscape underneath the "CedarNet
Template" image in the header.)

I just visited this page and it worked fine for me.

The image first shows up as a dot, then after a pause while it loads, it redraws
properly.  The length of this pause is dependent on you connection speed, and
could be quite significant over a slow connection like a modem.  Here on the
Ethernet, it is under one second.

Marking this bug "Works For Me"

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
In the June 10th Build, I cannot reproduce the problem described.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 6

19 years ago
There is still problems loading the page with M7, now with weird tiling effects
on the background images that should not be there, and were not there before.

I am using a 28.8 connection, but that is no excuse for the page to not load all
the way. A different server (http://204.71.100.80/template/) yeilds the same
problem.

I can send you a screenshot if you need a more definite idea of what is going
on.

That page is again located at http://www.cedarnet.org/template/

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 7

19 years ago
Clearing WorksForMe resolution.

Updated

19 years ago
Status: REOPENED → ASSIGNED
Summary: Image with no specified size shows up as a dot → Table background image tiles page background image.
Whiteboard: [TESTCASE] pollmann
Target Milestone: M7 → M8

Comment 8

19 years ago
Are you still seeing the "image as a dot" problem?  I was never able to
reproduce it.  As I mentioned before, the page always did load completely for
me.  The html page loads first.  During this load time, the images are displayed
as a dot (their size is not specified so the browser can not possibly know how
much space to allocate for them)  The images are then loaded, and the dots are
replaced by the images.  The page always completed loading for me.  Is it
finishing for you, given enough time?

If the images eventually load, this is the intended behavior and not a bug.  If
the image never loads, even after waiting a good deal of time, please try to
give more specifics on your connection speed, how long you waited, if the
throbber animation in the top-right corner stopped, ...

As to the background image 'tiling' effect, this is caused by the background
image specified for the table in your "columnbox" div, and it went away when I
removed this attribute.  This is a bug.

Since I can only find this one bug, I'm changing the summary to reflect the
discovered bug.  I've created a reduced testcase for this bug and am attaching
it.

Comment 9

19 years ago
Created attachment 576 [details]
Reduced test case, table background tiling

Updated

19 years ago
Assignee: pollmann → dcone
Status: ASSIGNED → NEW

Comment 10

19 years ago
Don, I hear you're working on background issues like this, can you take a look?
Thanks!
(Reporter)

Comment 11

19 years ago
Yes, the pages are still not loading all the way. I have noticed it with many
pages now, including Mozillazine. I am using M7 as of present.

The loading just "cuts out" with the throbber stopping. It cuts out after only
about five seconds of loading. Early releases of Seamonkey did not do this.

I am using a 28.8 connection.

Thanks for taking care of the other bug.

-Eric
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M10
(Reporter)

Comment 12

19 years ago
>As to the background image 'tiling' effect, this is caused by the background
>image specified for the table in your "columnbox" div, and it went away when I
>removed this attribute.  This is a bug.

This bug is still present in the nightly builds.

ALSO, the pages now seem to load all the way for me, but the image that
appeared as a dot before, now appears as the ALT text instead.

ALSO, if I go to a page with a similar format to the www.cedarnet.org/template
page, after loading the page, it will loose its formatting. ex.
www.cedarnet.org/education
(Reporter)

Comment 13

19 years ago
I wonder if the loss of formatting has do to with the pages sharing a
stylesheet?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
In the Aug 16th build, the problem appears to be fixed.
You need to log in before you can comment on or make changes to this bug.