If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

-moz-float-edge sucks; especially with auto margins and left floaters

RESOLVED WORKSFORME

Status

()

Core
Layout: Floats
P3
normal
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: Hixie (not reading bugmail), Unassigned)

Tracking

({css-moz})

Trunk
Future
x86
Windows 2000
css-moz
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P3] (because of effects on floats, lists, and the like) (may be replaced by float-displace and indent-edge-reset), URL)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   1. float something to the left.
   2. immediately after it, create an in-flow box with 
        -moz-float-edge: margin-box;
        margin: 1em auto;
   3. lay it out.

EXPECTED RESULTS
   in-flow box should be centered in remaining space, and otherwise look
   normal (only high enough for its contents, etc.):

   +-----------------------------------------------------+
   |                                                     |
   |    +-------------------+    +--------------------+  |
   |    | left floater      |    |  centered text     |  |
   |    +-------------------+    +--------------------+  |
   |                                                     |
   +-----------------------------------------------------+


ACTUAL RESULTS
   the left floater doesn't affect the centering, unlike with right floaters.

   +-----------------------------------------------------+
   |                                                     |
   |    +----------+--------+-----------+                |
   |    | left floa|ecentere| text      |                |
   |    +----------+--------+-----------+                |
   |                                                     |
   +-----------------------------------------------------+

See test case.
(Reporter)

Updated

17 years ago
Blocks: 38370

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 69490 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified duplicate submission
Status: RESOLVED → VERIFIED
Nope, these were actually different bugs with distinct test cases and
descriptions.  Please be more careful of what you are doing.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
Yikes! My mistake. I would have sworn that these were the same bug when I was
comparing them. Perhaps I had two of the same window open and didn't realize it.
I'll be more careful.

Comment 5

17 years ago
Accepting.
Status: REOPENED → ASSIGNED
(Reporter)

Updated

17 years ago
Whiteboard: [Hixie-P3] (because of effects on floats, lists, and the like) (may be replaced by float-displace and indent-edge-reset)
(Reporter)

Comment 6

17 years ago
Note that this happens with all but content-box:
   http://www.hixie.ch/tests/adhoc/css/mozilla/float-edge/005.html content (ok)
   http://www.hixie.ch/tests/adhoc/css/mozilla/float-edge/006.html border
   http://www.hixie.ch/tests/adhoc/css/mozilla/float-edge/007.html padding
   http://www.hixie.ch/tests/adhoc/css/mozilla/float-edge/008.html margin
Keywords: css-moz

Updated

16 years ago
Target Milestone: --- → mozilla1.1

Comment 7

15 years ago
Marc, could you update target milestone? 
Attinasi is no longer with NS.
Target Milestone: mozilla1.1alpha → ---

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Updated

15 years ago
Component: Layout → Layout: Floats
(Reporter)

Comment 9

15 years ago
.
Assignee: attinasi → float
Status: ASSIGNED → NEW
QA Contact: cpetersen0953 → ian
Blocks: 143162
(Reporter)

Comment 10

15 years ago
This appears to work now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.