Last Comment Bug 695051 - IonMonkey: Remove all references to jsc::ARMAssembler
: IonMonkey: Remove all references to jsc::ARMAssembler
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 10:42 PDT by Marty Rosenberg [:mjrosenb]
Modified: 2011-10-28 15:09 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove the last references to JSC::ARMAssembler from Ion code (19.41 KB, patch)
2011-10-17 10:42 PDT, Marty Rosenberg [:mjrosenb]
dvander: review+
Details | Diff | Review

Description Marty Rosenberg [:mjrosenb] 2011-10-17 10:42:28 PDT
Created attachment 567489 [details] [diff] [review]
remove the last  references to JSC::ARMAssembler from Ion code

Mostly pretty clean.  I'd been avoiding this because some files referred directly to MacroAssembler.h.  This has been changed to a conditional inclusion based on the target not being arm.
This should also speed up compilation, since every file that includes IonRegisters (most of the ion codebase) no longer needs to compile every function in the old assembler and macro assembler.
Comment 1 David Anderson [:dvander] 2011-10-21 17:29:22 PDT
Comment on attachment 567489 [details] [diff] [review]
remove the last  references to JSC::ARMAssembler from Ion code

Review of attachment 567489 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, sorry for the late review

::: js/src/ion/IonRegisters.h
@@ +58,1 @@
>  namespace js {

Nit: Newline between #endif and namespace

@@ +67,2 @@
>      typedef JSC::MacroAssembler::RegisterID RegisterID;
> +#endif

If you put "typedef JSC::MacroAssembler::Register RegisterID" in x86 and x64's Registers, we can get rid of the #ifdef here.

::: js/src/ion/arm/Architecture-arm.h
@@ +42,5 @@
>  #ifndef jsion_architecture_arm_h__
>  #define jsion_architecture_arm_h__
> +#include <limits.h>
> +#include "jscntxt.h"
> +//#include "assembler/assembler/ARMAssembler.h"

Nit: delete this line

::: js/src/ion/arm/Assembler-arm.h
@@ +42,5 @@
>  #ifndef jsion_cpu_arm_assembler_h__
>  #define jsion_cpu_arm_assembler_h__
>  
>  #include "ion/shared/Assembler-shared.h"
> +//#include "assembler/assembler/ARMAssembler.h"

Nit: delete this line
Comment 2 David Anderson [:dvander] 2011-10-28 15:09:38 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/2b94770c2bf8

Note You need to log in before you can comment on or make changes to this bug.