If you close the main window, commands like 'Quit' and 'New window' don't work

RESOLVED DUPLICATE of bug 68766

Status

--
critical
RESOLVED DUPLICATE of bug 68766
18 years ago
14 years ago

People

(Reporter: thomas, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.8) Gecko/20010219
BuildID:    2001021908

If you close the main window, items in the File menu like New Window or Quit
don't work anymore. The only way to quit Moz is then to do Apple-Opt-Esc
(Macintosh). And, when you do this (you have to do this twice), the Internet
Connection brokes : i can't go on any site using any browser.

Reproducible: Always
Steps to Reproduce:
0. Close the main window
1. Try to quit Moz (File menu) or to open a new window.
2. Do Apple-Opt_Esc until Moz quits
3. Try pinging any Web site

Actual Results:  I have to do Pomme-Opt Esc to quit Moz and  when I do this, my
Internet connection brokes.

Expected Results:  Mozilla should have quitted / opened a new window correctly !

Comment 1

18 years ago
Dupe of bug 68766.
By the way, you can double click any of Mozilla file from Finder, drag and drop
a file onto a Mozilla icon in the Finder, or if your Internet control panel is
set to use Mozilla as a default browser, opening a URL from Sherlock will start
a new window in Mozilla, and you can get the menu working again.

*** This bug has been marked as a duplicate of 68766 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
>or if your Internet control panel is
>set to use Mozilla as a default browser,

BTW : If I select Mozilla in IC and if I click on a link, Moz doesn't start (freezes after the component registration). I have to launch it manually.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.