Last Comment Bug 695165 - Forward
: Forward
Status: VERIFIED FIXED
: feature
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: ---
Assigned To: away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 697732
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 14:23 PDT by Erin Lancaster [:elan]
Modified: 2016-07-29 14:19 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
(1/3) Minor cleanup in Tab.java (2.95 KB, patch)
2011-10-27 08:31 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
sriram.mozilla: review+
Details | Diff | Splinter Review
(2/3) Plumbing for Forward (6.21 KB, patch)
2011-10-27 08:33 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
sriram.mozilla: review+
Details | Diff | Splinter Review
(3/3) Hook up forward as menu item (6.32 KB, patch)
2011-10-27 08:34 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
sriram.mozilla: review+
Details | Diff | Splinter Review
(1/2) Add plumbing for forward (3.20 KB, patch)
2011-10-28 06:53 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
mark.finkle: review+
Details | Diff | Splinter Review
(2/2) Hook up forward as menu item (6.16 KB, patch)
2011-10-28 06:53 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
bugmail: review+
Details | Diff | Splinter Review
(3/2) Rename events for consistency (4.05 KB, patch)
2011-10-28 07:03 PDT, away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
mark.finkle: review+
Details | Diff | Splinter Review

Description Erin Lancaster [:elan] 2011-10-17 14:23:58 PDT

    
Comment 1 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-27 07:24:50 PDT
I can put in the plumbing for this pending UX mockups.
Comment 2 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-27 08:31:48 PDT
Created attachment 569986 [details] [diff] [review]
(1/3) Minor cleanup in Tab.java
Comment 3 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-27 08:33:30 PDT
Created attachment 569987 [details] [diff] [review]
(2/3) Plumbing for Forward

I found this led to much simpler code than turning mHistory into a list and keeping an index pointer. That approach has lots of corner cases when the list is empty, or the index is out of bounds.
Comment 4 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-27 08:34:42 PDT
Created attachment 569988 [details] [diff] [review]
(3/3) Hook up forward as menu item

Making this a separate change so that it can be backed out if UX changes without affecting the plumbing part.
Comment 5 Sriram Ramasubramanian [:sriram] 2011-10-27 10:09:03 PDT
Comment on attachment 569987 [details] [diff] [review]
(2/3) Plumbing for Forward

Is there a reason for using 2 stacks? We need to pop from one and push into another. Why not have a List<HistoryEntry> and use an index variable? That operation is faster I guess.
Comment 6 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-28 06:52:09 PDT
Comment on attachment 569986 [details] [diff] [review]
(1/3) Minor cleanup in Tab.java

Moved this patch to 697732, since those patches need to go in first.
Comment 7 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-28 06:53:07 PDT
Created attachment 570248 [details] [diff] [review]
(1/2) Add plumbing for forward

This patch applies on top of the ones from bug 695165
Comment 8 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-28 06:53:57 PDT
Created attachment 570249 [details] [diff] [review]
(2/2) Hook up forward as menu item

Rebased the old patch, but no functional changes.
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-28 06:56:59 PDT
Drive-by:

* Could we change "session-*" messages to "Session:*" ?
Comment 10 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2011-10-28 07:03:50 PDT
Created attachment 570252 [details] [diff] [review]
(3/2) Rename events for consistency
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-28 07:08:17 PDT
Comment on attachment 570252 [details] [diff] [review]
(3/2) Rename events for consistency

Thanks
Comment 13 Aaron Train [:aaronmt] 2011-10-31 12:47:06 PDT
20111031103218
http://hg.mozilla.org/projects/birch/rev/9f5570d58bca
Samsung Galaxy SII (Android 2.3.4)

Note You need to log in before you can comment on or make changes to this bug.