Last Comment Bug 695214 - XPIDL compiler should enforce [retval] parameters coming last
: XPIDL compiler should enforce [retval] parameters coming last
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Nathan Froyd [:froydnj]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 15:54 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-03-20 03:51 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.47 KB, patch)
2012-03-13 13:53 PDT, Nathan Froyd [:froydnj]
khuey: review+
Details | Diff | Splinter Review

Description Bobby Holley (:bholley) (busy with Stylo) 2011-10-17 15:54:01 PDT
It doesn't currently do this. This is bad, because we assume this to be the case within XPConnect.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-10-19 13:07:31 PDT
They have to be last? That's new to me!
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-10-19 13:10:13 PDT
http://mxr.mozilla.org/mozilla2.0/source/xpcom/typelib/xpidl/xpidl_util.c#661
Comment 4 Mozilla RelEng Bot 2012-03-13 14:00:00 PDT
Autoland Patchset:
	Patches: 605526
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=8344741fc63b
Try run started, revision 8344741fc63b. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=8344741fc63b
Comment 5 Mozilla RelEng Bot 2012-03-13 19:02:55 PDT
Try run for 8344741fc63b is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=8344741fc63b
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-8344741fc63b
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-03-19 15:54:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/879bb8e92148
Comment 7 Mounir Lamouri (:mounir) 2012-03-20 03:51:32 PDT
https://hg.mozilla.org/mozilla-central/rev/879bb8e92148

Note You need to log in before you can comment on or make changes to this bug.