Last Comment Bug 695231 - Disable animated orientation change in Meegotouch window/scene manager
: Disable animated orientation change in Meegotouch window/scene manager
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Qt (show other bugs)
: Trunk
: ARM Maemo
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 16:54 PDT by Oleg Romashin (:romaxa)
Modified: 2011-10-18 13:24 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Force rotation without fade transition. (1.68 KB, patch)
2011-10-17 16:56 PDT, Oleg Romashin (:romaxa)
jeremias.bosch: review+
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2011-10-17 16:54:32 PDT
It seems latest meegotouch doing animated transition by default, and that is not working correctly because fennec using own GL context
Also very often we are getting crash:
PVR:Aborting: Offset to VBO out of bounds. Likely an app bug in glVertexAttribPointer! [213, validate.c]
which is related to old bug 618765
...
Suggesting just make rotation transition immediate by default
Comment 1 Oleg Romashin (:romaxa) 2011-10-17 16:56:16 PDT
Created attachment 567624 [details] [diff] [review]
Force rotation without fade transition.
Comment 2 Jeremias Bosch (:jbos) 2011-10-18 06:58:12 PDT
Comment on attachment 567624 [details] [diff] [review]
Force rotation without fade transition.

Review of attachment 567624 [details] [diff] [review]:
-----------------------------------------------------------------

Perfect. Ship it.
Comment 3 Oleg Romashin (:romaxa) 2011-10-18 13:24:20 PDT
https://hg.mozilla.org/mozilla-central/rev/7f6ff9f22d6f

Note You need to log in before you can comment on or make changes to this bug.