Upgrade websockets implementation to hybi draft 17

RESOLVED DUPLICATE of bug 666349

Status

()

Core
Networking: WebSockets
RESOLVED DUPLICATE of bug 666349
7 years ago
7 years ago

People

(Reporter: jduell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We should do this ASAP, so we'll have fewer changes to make when the final version of the spec is released.  But I'm not sure we ever want to ship a ws-17 implementation--may depend on what other browsers choose to do, and/or whether we're willing to implement support for multiple version of the spec via the Sec-WebSocket-Version header.
Draft-17 has moved to proposed standard and is in the RFC Editor's queue for some IANA registrations right now.

This is the stable IETF standard for the websocket protocol and what we want to implement unprefixed. It's sec-websocket-version header is 13.

There is no need to be backwards compatible with old prefixed imlpementations based on work in progress drafts. That's kinda the point of prefixing them - to not fragment the internet with upgrades.

But it is important to get this out quickly so that implementors don't depend on those old versions.
(Reporter)

Updated

7 years ago
Blocks: 695635
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666349
You need to log in before you can comment on or make changes to this bug.