Last Comment Bug 695364 - "ASSERTION: selection could not be collapsed after undo of deletetext" when loading editor/libeditor/base/crashtests/633709.xhtml after bug 688789
: "ASSERTION: selection could not be collapsed after undo of deletetext" when l...
Status: RESOLVED FIXED
[fixed by bug 612128]
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: :Ehsan Akhgari
:
: Makoto Kato [:m_kato]
Mentors:
Depends on: 612128
Blocks: 688789
  Show dependency treegraph
 
Reported: 2011-10-18 09:50 PDT by :Ehsan Akhgari
Modified: 2012-05-10 11:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Ehsan Akhgari 2011-10-18 09:50:04 PDT
This test does a bunch of crazy stuff, some of which used to fail before bug 688789.  Now they succeed, and we end up deleting a textnode while an input has focus, which causes IsValidSelectionPoint to fail (because the input has focus and the selection is outside of it, and we end up asserting.

Bug 688789 makes us better over all, and I think we should just fix this assertion when we get a saner behavior in this test case (such as not inserting "X" tags under an input element!!!)
Comment 1 :Ehsan Akhgari 2011-10-20 11:03:30 PDT
This is fixed by bug 612128:

https://hg.mozilla.org/integration/mozilla-inbound/rev/a4d5ca366ef1

Note You need to log in before you can comment on or make changes to this bug.