Cannot switch keyboard input layouts (by menu) on Account setup|passwd dialog and new/edit abook card window

RESOLVED DUPLICATE of bug 21296

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 21296
18 years ago
17 years ago

People

(Reporter: Wesley George, Assigned: Dan M)

Tracking

({intl})

Trunk
Future
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
<Environment>
Build 02-19-04 + Mac OS 9.04-JA

not repro on:
Build 02-19-04 + Windows

<Repro Steps>
1. Setup a password for a Mail server account with a given keyboard layout 
(e.g., U.S.)
2. Close Netscape 6
3. Reopen Netscape 6, change the keyboard layout selection (e.g., to Russian)
2. Click the Inbox for the mail server account requiring manual input of a
password
   >>Mail Server Password Required dialog pops-up
3. Try switching the keyboard layout back to U.S. so you can type the password.

<Result>
Cannot switch keyboard input layouts while the Mail Server Password Required 
dialog is active.

<Expected>
Should be able to switch layouts when focus is in the dialog.  

The workaround now is to Cancel the dialog, change the keyboard input layout 
selection, then re-invoke the Mail Server Password Required dialog.
(Reporter)

Updated

18 years ago
Keywords: intl

Comment 1

18 years ago
Keyboard short cut, command (i.e Apple) + space works.
Looks like this is a generic restriction in our modal dialog. You cannot access
the script menu in the preference dialog while a modal dialog is up.
Summary: Cannot switch keyboard input layouts while the Mail Server Password Required dialog is active. → Cannot switch keyboard input layouts (by menu) while the Mail Server Password Required dialog is active.

Updated

18 years ago
Product: MailNews → Browser

Comment 2

18 years ago
Reassign to xp toolkit.
Assignee: nhotta → trudelle
Component: Internationalization → XP Toolkit/Widgets

Comment 3

18 years ago
->danm/future
Assignee: trudelle → danm
Target Milestone: --- → Future

Comment 4

17 years ago
*** Bug 72593 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

17 years ago
Future fix should be verified with the profile manager's create profile/rename 
profile text field as well.

Comment 6

17 years ago
*** Bug 73705 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
This problem also exists on ABook card New/Edit window.

Comment 8

17 years ago
*** Bug 84837 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
As a workaround, command key + space bar can be used to switch the keyboard.
Summary: Cannot switch keyboard input layouts (by menu) while the Mail Server Password Required dialog is active. → Cannot switch keyboard input layouts (by menu) on passwd dialog and new/edit abook card window

Comment 10

17 years ago
Please note that this bug shows up in the most important instances: creating of
the profile, acoount setup , password dlgbox. As much as the workaround helps
please consider to fix in emojo. Changed summury
Summary: Cannot switch keyboard input layouts (by menu) on passwd dialog and new/edit abook card window → Cannot switch keyboard input layouts (by menu) on Account setup|passwd dialog and new/edit abook card window

Comment 11

17 years ago
i think we have to nominate this bug as nsbeta1 because it is one of the most
annoying intl Mac bugs ( you first encounter it when creating a new profile,
then account setup, the password dlgbox, etc...)

Comment 12

17 years ago
Second Marina's opinion. Added nsbeta1 keyword.
Keywords: nsbeta1

Comment 13

17 years ago

*** This bug has been marked as a duplicate of 21296 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.