Closed Bug 695436 Opened 8 years ago Closed 8 years ago

cfx won't be able to test extensions in future versions of Firefox

Categories

(Add-on SDK Graveyard :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mossop, Assigned: mossop)

References

Details

(Whiteboard: [cherry-pick-1.2])

Attachments

(1 file)

Attached patch patch rev 1Splinter Review
When bug 693743 lands (which is likely to happen for Firefox 8) cfx's current method of installing extensions into a test profile to test is going to be broken unless we tweak a pref to allow it again.

My git foo is pretty weak right now but this patch should correct it. It is basically risk free, the pref does nothing in Firefox <8, in Firefox 8, if bug 693743 doesn't land then the pref has the same value as that we're using here and if bug 693743 does land then using this value will keep profile extensions working. Verified in a local build with 'cfx testall'
Attachment #567834 - Flags: review?(warner-bugzilla)
Blocks: 694636
Duplicate of this bug: 695435
Comment on attachment 567834 [details] [diff] [review]
patch rev 1

looks good. want me to land it?
Attachment #567834 - Flags: review?(warner-bugzilla) → review+
https://github.com/mozilla/addon-sdk/commit/be374df09efe82d44b8c66f8a7e9ea5162c979eb
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [cherry-pick-wanted]
Target Milestone: --- → 1.2
Depends on: 693743
https://github.com/mozilla/addon-sdk/commit/28c99f20a169499fde68fbbc31efd4fa3ebfae1b
Priority: -- → P1
Whiteboard: [cherry-pick-wanted] → [cherry-pick-1.2]
You need to log in before you can comment on or make changes to this bug.