Last Comment Bug 695788 - SDK Firefox minVersion value unacceptable to AMO
: SDK Firefox minVersion value unacceptable to AMO
Status: RESOLVED FIXED
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: P1 blocker (vote)
: 1.2
Assigned To: Myk Melez [:myk] [@mykmelez]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 11:53 PDT by Myk Melez [:myk] [@mykmelez]
Modified: 2011-11-29 14:17 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Myk Melez [:myk] [@mykmelez] 2011-10-19 11:53:35 PDT
According to Carey in the discussion forum <https://groups.google.com/forum/#!topic/mozilla-labs-jetpack/DVYF0qa8XVQ>, SDK 1.2's Firefox minVersion of "7" is unacceptable to AMO, which requires it to be "7.0a1, 7.0a2, 7.0, 7.*".

I just confirmed the problem by creating a simple addon using `cfx init` and then trying to upload it to AMO.  The addon failed validation with the error:

--------------------------------------------------------------------------------
Invalid minimum version number

Error: The minimum version that was specified is not an acceptable version number for the Mozilla product that it corresponds with.

Error: Version "7" isn't compatible with "firefox".

Error: Please check the list of valid versions at: https://addons.mozilla.org/en-US/firefox/pages/appversions/
install.rdf
--------------------------------------------------------------------------------

However, manually installing the XPI into Firefox 7.0.1 works, so the browser itself understands that "7" is a valid minimum version.

This is a terrible problem with the new release, because it means that no addons created with it can be distributed on AMO!

The two options for resolving it that I can think of right now are:

1. Issue an SDK hotfix release, 1.2.1, with a minimum version of 7.0.
2. On AMO, add "7" as a valid minimum version.

Of those, option #2 seems better, because we wouldn't have to spin a new release, take in through testing, and somehow get folks who downloaded 1.2 to download the new version (which is hard because we don't have an auto-update mechanism for the SDK).

fligtar: would option #2 be possible?
Comment 1 Justin Scott [:fligtar] 2011-10-19 12:17:49 PDT
It's possible to add 7, but it will be the first time we've ever had such a minVersion on AMO or promoted using such a version number. My 2 concerns would be:

* as we've never used this on AMO, we haven't done any testing to ensure it works with everything that depends on version checking: install buttons, finding the latest version to display, update checks, compatibility tools, etc.

* it's confusing enough for developers to have both 7.0 and 7.* as options (many set 7.0 as a maxVersion which makes it uninstallable in most releases) and I'd hate adding inconsistency into the mix.

So, I'm hesitant to add 7 as a quick fix since we don't know the consequences. Do we know how many downloads of the new version there have been, or how many add-ons are affected?
Comment 2 Wes Kocher (:KWierso) 2011-10-19 12:21:09 PDT
Just as a note, stabilization branch's minVersion is set to "8", so the same change will have to happen there as well. 

Master branch is correctly set at "9.0a1".
Comment 3 David Mason [:dcm :dmason] 2011-10-19 12:42:40 PDT
OK - so we still dont get metrics on the number of downloads for the SDK (another issue). Given that, and the fact that its probably easier for us to test than for all of AMO to test, we will spin a hotfix release.

Thanks for the info fligtar.
Comment 5 [github robot] 2011-11-29 14:17:48 PST
Commit pushed to https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/2d69062dbc2394aeb4b469aa3acbeddb9d1d3bad
bug 695788: set Firefox minVersion to value that is acceptable to AMO

Note You need to log in before you can comment on or make changes to this bug.