The url status panel doesn't go away if the hyperlink is removed on click

REOPENED
Unassigned

Status

()

Core
Event Handling
REOPENED
7 years ago
26 days ago

People

(Reporter: Cork, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

611 bytes, text/html
Details
681 bytes, text/html
Details
(Reporter)

Description

7 years ago
Created attachment 568177 [details]
testcase

Webpages that use link tags for javascript actions and puts things in the href (normally # or javascript:void(0)) leaves the get a zombi url status panel and doesn't go away until you hover another link in the page.

It doesn't matter if the element it self, its parent or grand parent is removed.

This wasn't caused by the removing of the status bar but as its now covers the content its gotten worse.

STR:
1. Open the testcase
2. Click one of the link and make sure not to hove the other one

Expected result:
The status panel should go away when the link element isn't there anymore

Actual result:
The status panel stays around indefinitely if you don't have another link you can hover.
(Reporter)

Updated

7 years ago
Keywords: testcase
(Reporter)

Updated

4 years ago
Flags: firefox-backlog?

Updated

4 years ago
Flags: firefox-backlog? → firefox-backlog+
Whiteboard: p=0
Testcase works for me
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Created attachment 8418217 [details]
updated testcase

huh.. weird, well here is a slightly updated testcase that shows the same bug in nightly.
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Flags: firefox-backlog+

Updated

4 years ago
Whiteboard: p=0
Moving this to Core as I don't think this is a front-end bug. The API on the front-end is just a SetStatus function which hides the status bar when it's passed an empty string. Docshell/ESM usually calls it with the right url/empty string.

Element::LeaveLink is the function to be called to clear the string (hide the panel). It appears that there is code that handles calling it when a node is removed, here:
http://hg.mozilla.org/mozilla-central/annotate/a8602e656d86/dom/events/EventStateManager.cpp#l4682

But for some reason the testcase posted doesn't hit it.
Component: General → Event Handling
Product: Firefox → Core

Updated

2 years ago
See Also: → bug 1239048

Updated

26 days ago
See Also: → bug 1438660
You need to log in before you can comment on or make changes to this bug.