http://smartusa.com/ thinks Fx 10.0a1 is an "older version" of Firefox

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: jbalogh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Someone tried to show me some fancy effects they're doing on that page but I wasn't seeing anything interesting. I found this in their js:

    <!-- REDIRECT - OLDER BROWSERS to ORIGINAL WEBSITE -->
    if (($.browser.mozilla) && ($.browser.version < "3.4.0")) { window.location.replace(url); }

That's some awful coding and it fails since "10.0a1" < "3.4.0" when you're comparing strings.

Updated

8 years ago
Blocks: 690287
OS: Mac OS X → All
Hardware: x86 → All
Anyone tried to reach them?
Jeff, could you confirm that the problem is still there?
(Reporter)

Comment 3

7 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #2)
> Jeff, could you confirm that the problem is still there?

It is. If I go to http://www.smartusa.com/ in Chrome I get a fancy page; if I go there in Firefox I get bounced to http://www.smartusa.com/home/overview.aspx.

Still the same piece of code:

    <!-- REDIRECT - OLDER BROWSERS to ORIGINAL WEBSITE -->                      
    <script type="text/javascript">                                             
        var url = "http://www.smartusa.com/home/overview.aspx";                 
        if (($.browser.msie) && ($.browser.version < "7")) { window.location.replace(url); }
        if (($.browser.mozilla) && ($.browser.version < "3.4.0")) { window.location.replace(url); }
        if (($.browser.safari) && ($.browser.version < "4")) { window.location.replace(url); }                                                                                      
    </script>
(In reply to Jeff Balogh (:jbalogh) from comment #0)
>     <!-- REDIRECT - OLDER BROWSERS to ORIGINAL WEBSITE -->
>     if (($.browser.mozilla) && ($.browser.version < "3.4.0")) {
> window.location.replace(url); }
> 
> That's some awful coding and it fails since "10.0a1" < "3.4.0" when you're
> comparing strings.

Furthermore, it totally ignores the fact that not all "Mozilla" browsers are Firefox and don't all use the same versioning system, so even if the comparison was valid, it would be incorrect for Camino and Seamonkey users.

I'm more interested in an answer to comment 1, though :-p
It looks like they fixed it. Jeff could you confirm?
Sorry for the spam, I was using UA spoofing. The site is not fixed.
I've sent them a message via their contact form. The new site is working well when I fake the UA.
Did this get fixed?  The site looks pretty fancy to me.
Not for me (Nightly + UA of Fx 10). (Try to fake to Chrome 17 to see the difference!).

(The site is *really* fancy)
Same site as Chrome now. Closing as FIXED.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.