TR tags don't expose their ID attribute to DOM

VERIFIED FIXED

Status

()

Core
DOM
P2
normal
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: Angus Davis, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
See URL for test case - watch stdout for the alerts. Currently it returns an
empty string, rather than "mytr" (expected) or even null/undefined.
(Assignee)

Comment 1

19 years ago
Please retest with latest code (as of 8/27/98).  Peter checked in some code that
should have fixed this and related attribute-in-table bugs.
(Reporter)

Updated

19 years ago
Assignee: angus → buster
Component: Unknown → DOM
(Reporter)

Comment 2

19 years ago
reassigning to buster
(Reporter)

Updated

19 years ago
(Reporter)

Comment 3

19 years ago
Pushing testcase to mozilla.org and updating "URL" field accordingly
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
The test case now works as a result of the new content model table code, as
evidenced by the debug output ("ID attribute is: mytr")

Updated

19 years ago

Comment 5

19 years ago
stdout returns "ID attribute is: mytr"
marking this verified fixed with the 11/30 build on NT/win98.

Comment 6

11 years ago
RCS file: /cvsroot/mozilla/testing/mochitest/tests/test_bug696.html,v
done
Checking in tests/test_bug696.html;
/cvsroot/mozilla/testing/mochitest/tests/test_bug696.html,v  <--  test_bug696.html
initial revision: 1.1
done
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.