Last Comment Bug 696014 - [hu] Remove Bluu search engine from Hungarian builds
: [hu] Remove Bluu search engine from Hungarian builds
Status: VERIFIED FIXED
[qa!]
: verified-aurora, verified-beta
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Milos Dinic [:Milos]
: Andras Timar
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 02:53 PDT by Andras Timar
Modified: 2011-12-09 06:16 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (3.30 KB, patch)
2011-10-20 02:53 PDT, Andras Timar
themilossh: review+
Details | Diff | Review
remove bluu.xml from all versions during update (424 bytes, patch)
2011-11-17 01:47 PST, Andras Timar
themilossh: review+
nthomas: review+
Details | Diff | Review
remove bluu.xml from all versions during update, v2 (680 bytes, patch)
2011-11-24 17:34 PST, Nick Thomas [:nthomas]
nthomas: review+
christian: approval‑mozilla‑aurora+
christian: approval‑mozilla‑beta+
Details | Diff | Review

Description Andras Timar 2011-10-20 02:53:33 PDT
Created attachment 568346 [details] [diff] [review]
patch

Remove Bluu search engine from Hungarian Firefox, because their site has been down for several weeks and they do not reposond to e-mails.
Comment 1 Staś Małolepszy :stas 2011-10-25 04:58:58 PDT
Thanks for filing the bug, Andras.  I was out of the office for 2 weeks which is why I didn't comment earlier.

Milos, would you like to take that bug and help Andras?

Andras's patch looks good but it will only affect new installs.  To remove the plugin retroactively from the existing installs, we will need to add the xml file name to browser/installer/removed-files.in in mozilla-central (and possibly aurora and beta too).

CC'ing Axel, too.
Comment 2 Milos Dinic [:Milos] 2011-10-25 05:08:21 PDT
(In reply to Staś Małolepszy :stas from comment #1)
> Milos, would you like to take that bug and help Andras?

Sure!

Hey Andras,

Now that we're removing a search engine, would you like to use this bug and discuss possible replacements for this search engine, or you're good with removing it only, for now?
Comment 3 Andras Timar 2011-10-25 05:51:04 PDT
(In reply to Milos Dinic [:Milos] from comment #2)
Hi Milos,

Just remove it for the time being. I cannot think of a good replacement.
Comment 4 Milos Dinic [:Milos] 2011-10-26 01:45:28 PDT
Andras,

Ok. Can you please implement changes from Stas' comment 1, and attach a new patch?
Comment 5 Milos Dinic [:Milos] 2011-11-16 21:20:32 PST
Andras, ping. Do you still want this change?
Comment 6 Andras Timar 2011-11-17 01:47:36 PST
Created attachment 575120 [details] [diff] [review]
remove bluu.xml from all versions during update

Milos, yes, I still want this change. Please apply this patch to central, aurora, and beta. Also, please approve the first patch, I can commit it myself. And please, don't ask for more patches. You know what I want: remove bluu. You know how to do that. Why did I need to checkout the whole repo for a one liner patch? Thanks!
Comment 7 Milos Dinic [:Milos] 2011-11-17 02:45:09 PST
Comment on attachment 568346 [details] [diff] [review]
patch

Review of attachment 568346 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, as per previous comments. Please land with appropriate comment, mentioning this bug number, description and my approval(r=milos)
Comment 8 Milos Dinic [:Milos] 2011-11-17 02:48:58 PST
Comment on attachment 575120 [details] [diff] [review]
remove bluu.xml from all versions during update

Review of attachment 575120 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for this one, r+. Please land with the same descritpion(possibly in the same commit) as previous patch.

Now, as far as landing and patches are concerned, we prefer localizers have the full control over their repositories, so that's why we mainly don't commit. Of course, if you're really busy, or have problems with your computer, or anything else comes in your way that makes it hard for you to land your patches, I can give you a hand.
Comment 9 Andras Timar 2011-11-18 01:31:25 PST
I pushed the fix to all Hungarian l10n repos. The second patch is for browser/installer/removed-files.in in mozilla-central (and aurora, and beta), and I don't have write access, so can you please do it for me. Thanks,
Comment 10 Nick Thomas [:nthomas] 2011-11-22 19:50:30 PST
Comment on attachment 575120 [details] [diff] [review]
remove bluu.xml from all versions during update

I'd put it in between these two
 searchplugins/baidu.src
 searchplugins/bok-NO.gif
to maintain the alphabetical sort. Do you need someone to land this Milos ?
Comment 11 Staś Małolepszy :stas 2011-11-23 09:33:31 PST
Nick, Axel -- since the change to the Hungarian repo will happen on l10n/mozilla-aurora, should the removed-files.in patch land on both central and aurora?
Comment 12 Axel Hecht [:Pike] 2011-11-23 09:41:15 PST
Yes, and landing help would be appreciated.
Comment 13 Nick Thomas [:nthomas] 2011-11-24 17:34:58 PST
Created attachment 576841 [details] [diff] [review]
remove bluu.xml from all versions during update, v2

As landed:
 http://hg.mozilla.org/integration/mozilla-inbound/rev/a4492c6d02b0
Comment 14 Nick Thomas [:nthomas] 2011-11-24 17:36:34 PST
Hmm, there are no flags here to request approval for aurora or beta. How do you normally handle that Axel ?
Comment 15 Mounir Lamouri (:mounir) 2011-11-25 02:26:42 PST
https://hg.mozilla.org/mozilla-central/rev/a4492c6d02b0
Comment 16 Axel Hecht [:Pike] 2011-11-25 05:57:37 PST
(In reply to Nick Thomas [:nthomas] from comment #14)
> Hmm, there are no flags here to request approval for aurora or beta. How do
> you normally handle that Axel ?

Let's just move it to Firefox and use the flags there. There's really no "usually".
Comment 17 Axel Hecht [:Pike] 2011-11-25 06:00:48 PST
Comment on attachment 576841 [details] [diff] [review]
remove bluu.xml from all versions during update, v2

Requesting approval to land the removed-files.in patch in aurora and beta, to correspond with http://hg.mozilla.org/releases/l10n/mozilla-beta/hu/rev/f96dc0a754fd and http://hg.mozilla.org/releases/l10n/mozilla-aurora/hu/rev/6f67195ee19d
Comment 18 Nick Thomas [:nthomas] 2011-11-25 11:33:06 PST
FWIW, I have searched mxr's l10n indexes for aurora and beta and found no instances of bluu.xml, so no other locales are using this search engine.
Comment 19 Nick Thomas [:nthomas] 2011-11-28 15:21:35 PST
Comment on attachment 576841 [details] [diff] [review]
remove bluu.xml from all versions during update, v2

http://hg.mozilla.org/releases/mozilla-aurora/rev/187e2ae243b5
http://hg.mozilla.org/releases/mozilla-beta/rev/b100a8d12b9b
Comment 20 Nick Thomas [:nthomas] 2011-11-28 15:26:22 PST
All done.
Comment 21 Mihaela Velimiroviciu (:mihaelav) 2011-12-07 04:53:13 PST
Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111206 Firefox/11.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111206 Firefox/11.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1
Mozilla/5.0 (Windows NT 5.1; rv:11.0a1) Gecko/20111206 Firefox/11.0a1

Mozilla/5.0 (Windows NT 6.1; rv:10.0a2) Gecko/20111206 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111206 Firefox/10.0a2
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0a2) Gecko/20111206 Firefox/10.0a2
Mozilla/5.0 (Windows NT 5.1; rv:10.0a2) Gecko/20111206 Firefox/10.0a2

Bluu search engine was removed from Nightly and Aurora HU builds (above), but latest Betas (9 beta 4) still have it:
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-07 08:51:38 PST
Nick, can you comment on the claim that 9.0 Beta builds do not reflect this change?
Comment 23 Axel Hecht [:Pike] 2011-12-07 09:05:38 PST
That's consistent with http://hg.mozilla.org/releases/l10n/mozilla-beta/hu/graph/, b4 doesn't have this. B5 should, though.
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-07 09:12:51 PST
Mihaela, please retest this once we get 9.0b5 builds later this week.
Comment 25 Mihaela Velimiroviciu (:mihaelav) 2011-12-09 00:13:08 PST
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0

Verified on latest beta(9beta5) and the Bluu search engine was removed from HU builds.
Markiing as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.