hard crash when executing VERY simple javascript

VERIFIED DUPLICATE of bug 69607

Status

()

Core
JavaScript Engine
--
critical
VERIFIED DUPLICATE of bug 69607
17 years ago
17 years ago

People

(Reporter: Scott Kester, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i586; en-US; 0.8) Gecko/20010220
BuildID:    2001022012

This very short javascript code causes a crash ( or hung browser) on both linux
and windows.  Also this problem was not in the Feb 15 build, it appears to have
shown up on the 16th or 17th.  I have noticed that with just a slight change to
the code no crash occurs.

http://216.227.33.173/mozilla_test/js_ok.html

I just removed the else condition, and it does not crash.This bug may be related
to 66046 but I don't think so, since this just showed up in the latest builds.

The URLs given point to my server at home, and my DSL is acting up, so if it
does not work the first time, try back later.  Thanks.

Reproducible: Always
Steps to Reproduce:
1.Go to above URL, thats it.
2.
3.

Actual Results:  Crash.

Expected Results:  Should not crash.

Here is the html of the test case. It does not do very much, this is a very
reduced case from the script I found the bug on.

<html>
<head>
<title> True/False Test Crash</title>
</head>
<body>
This is a test case that will cause a crash.<br>
<script type="text/javascript">

var test1;
var test2;
var test3;

if( false){
    test1 = 1;
}else{
    test2 = 0;
}
if( false){
    test3 = 0;
}
</script>
End of test case.
</body>
</html>

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 69607 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.