Last Comment Bug 696288 - Regression: Processing.js Performance Tests don't work
: Regression: Processing.js Performance Tests don't work
Status: VERIFIED FIXED
[qa!][testcase: comment 3]
: regression, verified-aurora, verified-beta
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86_64 Windows 7
: P1 normal (vote)
: Firefox 10
Assigned To: Panos Astithas [:past]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
http://scotland.proximity.on.ca/dxr/t...
: 702928 (view as bug list)
Depends on:
Blocks: 614586
  Show dependency treegraph
 
Reported: 2011-10-20 18:24 PDT by David Mandelin [:dmandelin]
Modified: 2011-11-23 02:36 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed


Attachments
Simple fix (2.02 KB, patch)
2011-10-24 01:27 PDT, Panos Astithas [:past]
bugzilla: review+
bugs: review+
christian: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description David Mandelin [:dmandelin] 2011-10-20 18:24:37 PDT
[18:23:05.014] uncaught exception: TypeError: format.replace is not a function

9/20 nightly: works
9/21 nightly: doesn't work

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=09%2F19%2F2011&enddate=09%2F21%2F2011
Comment 1 David Mandelin [:dmandelin] 2011-10-21 16:17:01 PDT
I bisected this to http://hg.mozilla.org/mozilla-central/rev/8e3e1c5f348d

It appears that that patch introduces a call to |format.replace| on some paths called for console logging functions, and |format.replace| doesn't exist.
Comment 2 Panos Astithas [:past] 2011-10-22 02:58:52 PDT
How can I reproduce this failure?
Comment 3 David Humphrey (:humph) 2011-10-22 07:56:16 PDT
(In reply to Panos Astithas [:past] from comment #2)
> How can I reproduce this failure?

1) go here: http://scotland.proximity.on.ca/dxr/tmp/processing-js/test/perf/
2) click start
Comment 4 Panos Astithas [:past] 2011-10-24 01:27:47 PDT
Created attachment 569007 [details] [diff] [review]
Simple fix

A simple fix with a test.
Comment 5 Mozilla RelEng Bot 2011-10-24 05:10:19 PDT
Try run for 7e1cb1fada01 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=7e1cb1fada01
Results (out of 155 total builds):
    success: 152
    warnings: 2
    failure: 1
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/pastithas@mozilla.com-7e1cb1fada01
Comment 6 Rob Campbell [:rc] (:robcee) 2011-10-26 07:27:26 PDT
https://hg.mozilla.org/integration/fx-team/rev/7ba9a146e1e8
Comment 7 :Margaret Leibovic 2011-10-27 11:39:28 PDT
https://hg.mozilla.org/mozilla-central/rev/7ba9a146e1e8
Comment 8 Panos Astithas [:past] 2011-11-16 04:57:57 PST
*** Bug 702928 has been marked as a duplicate of this bug. ***
Comment 9 Panos Astithas [:past] 2011-11-16 05:00:29 PST
Comment on attachment 569007 [details] [diff] [review]
Simple fix

We forgot to get this into 9 when it was in aurora, can we get it into beta now?
Comment 10 christian 2011-11-22 09:56:51 PST
Comment on attachment 569007 [details] [diff] [review]
Simple fix

[triage comment]
Approved for beta. Please land today asap.
Comment 11 Rob Campbell [:rc] (:robcee) 2011-11-22 12:02:16 PST
http://hg.mozilla.org/releases/mozilla-beta/rev/3d16e65f9481
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-11-22 12:48:45 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #11)
> http://hg.mozilla.org/releases/mozilla-beta/rev/3d16e65f9481

Can we change status-firefox9 to fixed?
Comment 13 Mihaela Velimiroviciu (:mihaelav) 2011-11-23 02:07:03 PST
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0 (beta 3)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a2) Gecko/20111122 Firefox/10.0a2
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111122 Firefox/11.0a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111122 Firefox/11.0a1

Verified using the steps from comment #3: pressing "Start" started the tests run, although some tests failed. Should a separate bug be logged for that?
Comment 14 Rob Campbell [:rc] (:robcee) 2011-11-23 02:36:02 PST
(In reply to Mihaela Velimiroviciu [QA] from comment #13)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0 (beta
> 3)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a2) Gecko/20111122 Firefox/10.0a2
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111122
> Firefox/11.0a1
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111122 Firefox/11.0a1
> 
> Verified using the steps from comment #3: pressing "Start" started the tests
> run, although some tests failed. Should a separate bug be logged for that?

no. If the processing team finds bugs in that version, they should open new bugs for the regressions. Thanks for verifying.

Note You need to log in before you can comment on or make changes to this bug.