Add check for out-of-date Java on What's New Pages

RESOLVED WONTFIX

Status

www.mozilla.org
General
--
critical
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Add check for out-of-date Java on 7.0.1 and 8.0 What's New Pages.

For background, see bug 689661 comment 57.
The what's new pages for 7.0 are not shown to users and I don't think they will be for 8.0.

So I think it's not the best way to communicate with users anymore.
(Reporter)

Comment 2

6 years ago
(In reply to Anthony Ricaud (:rik) from comment #1)
> So I think it's not the best way to communicate with users anymore.
Either use the 3.6.25 & 9.0 What's New pages or make the plugincheck page appear once.

Indeed, according to the latest npjp2.dll correlations in:
* 8.0, 45% of users still use a vulnerable Java version:
6.0.100.32	2008-10-15     0.05%
6.0.110.3	2008-12-03     0.14%
6.0.130.3	               0.38%
6.0.140.8	2009-05-28     0.05%
6.0.150.3	2009-08-04     0.19%
6.0.160.1	2009-08-11     0.14%
6.0.170.4	2009-11-24     0.34%
6.0.180.7	2010-01-13     0.24%
6.0.190.4	2010-03-30     0.24%
6.0.200.2	2010-04-15     3.02%
6.0.210.6	               0.43%
6.0.210.7	2010-07-07     2.44%
6.0.220.4	2010-10-12     6.70%
6.0.230.5	2010-12-08     2.30%
6.0.240.7	2011-02-15     6.13%
6.0.250.3	               0.05%
6.0.250.4	               0.05%
6.0.250.6	2011-03-21     1.34%
6.0.260.3	2011-06-07    16.00%
6.0.270.7	2011-08-16     4.60%
6.0.290.11	2011-10-18    55.12%
7.0.0.66	2011-07-07     0.05%

* 3.6.24, 74% of users still use a vulnerable Java version:
6.0.0.0	        2008-10-15     0.32%
6.0.130.3	               0.16%
6.0.160.1	2009-08-11     0.16%
6.0.180.7	2010-01-13     0.32%
6.0.190.4	2010-03-30     0.79%
6.0.200.2	2010-04-15    11.51%
6.0.210.6	               0.79%
6.0.210.7	2010-07-07     4.89%
6.0.220.4	2010-10-12    10.73%
6.0.230.5	2010-12-08     5.99%
6.0.240.7	2011-02-15    11.20%
6.0.250.6	2011-03-21     2.21%
6.0.260.3	2011-06-07    20.98%
6.0.270.7	2011-08-16     4.26%
6.0.290.11	2011-10-18    25.71%
Summary: Add check for out-of-date Java on 7.0.1 and 8.0 What's New Pages → Add check for out-of-date Java on What's New Pages
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
1. Outdated Java plug-ins are blocked by the Firefox blocklist.
https://addons.mozilla.org/en-US/firefox/blocked/

2. The Flash version detection on the whatsnew page has also been removed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.