Last Comment Bug 696353 - What happened to the arguments element IC ?
: What happened to the arguments element IC ?
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on: 703721
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-21 05:01 PDT by AWAY Tom Schuster [:evilpie]
Modified: 2012-01-12 14:20 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description AWAY Tom Schuster [:evilpie] 2011-10-21 05:01:43 PDT
My HG skill fail me a bit, but apparently since Type Inference, somebody removed the call to attachArguments in GetElementIC::update. I guess this has been disabled because TI can optimize arguments access. But this might still be a win, because from what i remember this optimization doesn't work cross-functions.
Comment 1 Brian Hackett (:bhackett) 2011-10-22 08:24:09 PDT
Looked around a bit ('hg log file -p' for a complete history of changes to a file), and the arguments IC has never actually been enabled.  Here is the original landing of bug 616744:

https://hg.mozilla.org/mozilla-central/rev/da50621162f3

attachArguments is defined but is not called anywhere.
Comment 2 AWAY Tom Schuster [:evilpie] 2012-01-12 14:20:00 PST
Brian activated the IC in Bug 703721.

Note You need to log in before you can comment on or make changes to this bug.