Closed Bug 696591 Opened 8 years ago Closed 7 years ago

Intermittent test_bfcache.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: philor, Assigned: khuey)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=6986612&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-2/5 on 2011-10-22 08:43:03 PDT for push 356cd0d8f5a1

829 INFO TEST-START | /tests/dom/indexedDB/test/test_bfcache.html
++DOMWINDOW == 179 (09DD6068) [serial = 1328] [outer = 07CFB250]
++DOCSHELL 0ABA6BE8 == 11
++DOMWINDOW == 180 (0ACD2758) [serial = 1329] [outer = 00000000]
++DOMWINDOW == 181 (0AC06618) [serial = 1330] [outer = 0ACD2708]
830 INFO TEST-PASS | /tests/dom/indexedDB/test/test_bfcache.html | don't double-enable bfcache - undefined should equal undefined
++DOMWINDOW == 182 (0998EEC8) [serial = 1331] [outer = 0ACD2708]
--DOMWINDOW == 181 (0B1F7430) [serial = 1315] [outer = 0A121568] [url = about:blank]
--DOMWINDOW == 180 (0B0AB4A8) [serial = 1298] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 179 (0A0BFE78) [serial = 1308] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test2</p>]
--DOMWINDOW == 178 (0A92B390) [serial = 1307] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 177 (0A7DF108) [serial = 1306] [outer = 00000000] [url = data:text/html,<p%20id='text'>Start</p>]
--DOMWINDOW == 176 (0AA54BB8) [serial = 1301] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/bug94514-postpage.html]
--DOMWINDOW == 175 (0A256428) [serial = 1300] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/bug94514-postpage.html?posted=1]
--DOMWINDOW == 174 (0B8339F0) [serial = 1299] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 173 (0BAB7F40) [serial = 1289] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_bug94514.html]
--DOMWINDOW == 172 (0A8D6A98) [serial = 1288] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 171 (0AF8CA30) [serial = 1285] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_bug680257.html]
--DOMWINDOW == 170 (0AD4F950) [serial = 1282] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_bug675587.html]
--DOMWINDOW == 169 (0B3E88A8) [serial = 1281] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/file_bug669671.sjs?hash-test#hash]
--DOMWINDOW == 168 (0ABE26E8) [serial = 1280] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/file_bug669671.sjs?navigated-3]
--DOMWINDOW == 167 (0A6AE288) [serial = 1279] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 166 (0C07C6A8) [serial = 1276] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/file_bug669671.sjs?replaced]
--DOMWINDOW == 165 (09325270) [serial = 1275] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/file_bug669671.sjs?navigated-2]
--DOMWINDOW == 164 (0A6EDD78) [serial = 1264] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_bug669671.html]
--DOMWINDOW == 163 (09DF23A8) [serial = 1291] [outer = 00000000] [url = about:blank]
--DOCSHELL 0AA7D5B8 == 10
--DOCSHELL 0A1217E8 == 9
--DOCSHELL 0A535588 == 8
--DOCSHELL 09F94D08 == 7
831 INFO TEST-PASS | /tests/dom/indexedDB/test/test_bfcache.html | set up database successfully - go should equal go
++DOMWINDOW == 164 (0A2E6C50) [serial = 1332] [outer = 0ACD2708]
xul!mozilla::gl::GLContextProviderEGL::operator=+0x00000000001D8149
xul!mozilla::gl::GLContextProviderEGL::operator=+0x00000000001C3CB5
xul!mozilla::gl::GLContextProviderEGL::operator=+0x00000000001ED773
xul!XRE_AddJarManifestLocation+0x0000000000006BD6
xul!XRE_AddJarManifestLocation+0x0000000000004EFA
xul!gfxAlphaRecovery::operator=+0x00000000000D2A6D
xul!XRE_AddJarManifestLocation+0x0000000000004543
nspr4!PRP_TryLock+0x00000000000005FB
MSVCR80D!beginthreadex+0x00000000000001C7
kernel32!GetModuleFileNameA+0x00000000000001B4
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file e:/builds/moz2_slave/m-in-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2550
--DOMWINDOW == 163 (0A4AC1B8) [serial = 1317] [outer = 00000000] [url = data:text/html,<p%20id='text'>Start</p>]
--DOMWINDOW == 162 (0A1215B8) [serial = 1314] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/historyframes.html]
--DOMWINDOW == 161 (0A792260) [serial = 1303] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/historyframes.html]
--DOMWINDOW == 160 (0B4C6EE8) [serial = 1310] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test2</p>]
--DOMWINDOW == 159 (0A901538) [serial = 1309] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 158 (0A3FEB68) [serial = 1304] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/historyframes.html]
--DOMWINDOW == 157 (0BCCC360) [serial = 1302] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_framedhistoryframes.html]
--DOMWINDOW == 156 (0AC06618) [serial = 1330] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 155 (0AAC4570) [serial = 1324] [outer = 00000000] [url = data:text/html,<p%20id='text'>Start</p>]
--DOMWINDOW == 154 (0B3C20E8) [serial = 1323] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 153 (0A8B45E8) [serial = 1322] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test2</p>]
--DOMWINDOW == 152 (0AA14990) [serial = 1321] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 151 (0BC83008) [serial = 1320] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test2</p>]
--DOMWINDOW == 150 (0AF81060) [serial = 1319] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 149 (0B065288) [serial = 1318] [outer = 00000000] [url = data:text/html,<p%20id='text'>Start</p>]
--DOMWINDOW == 148 (0B28FDE8) [serial = 1316] [outer = 00000000] [url = about:blank]
--DOMWINDOW == 147 (0AE5AE40) [serial = 1313] [outer = 00000000] [url = http://mochi.test:8888/tests/docshell/test/test_windowedhistoryframes.html]
--DOMWINDOW == 146 (0A6F9308) [serial = 1311] [outer = 00000000] [url = data:text/html,<p%20id='text'>Test1</p>]
--DOMWINDOW == 145 (0AAC37D0) [serial = 1327] [outer = 07CFB250] [url = http://mochi.test:8888/tests/dom/indexedDB/test/test_bad_keypath.html]
--DOMWINDOW == 144 (0B906638) [serial = 1325] [outer = 07CFB250] [url = http://mochi.test:8888/tests/dom/indexedDB/test/test_add_twice_failure.html]
WARNING: 1 sort operation has occurred for the SQL statement '0xa826500'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file e:/builds/moz2_slave/m-in-w32-dbg/build/storage/src/mozStoragePrivateHelpers.cpp, line 144
WARNING: 1 sort operation has occurred for the SQL statement '0x9975f48'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file e:/builds/moz2_slave/m-in-w32-dbg/build/storage/src/mozStoragePrivateHelpers.cpp, line 144
832 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_bfcache.html | Test timed out.
833 INFO TEST-END | /tests/dom/indexedDB/test/test_bfcache.html | finished in 327746ms
Blocks: idb
Component: Document Navigation → DOM
QA Contact: docshell → general
That this only happens on debug xp is really, really weird.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Uh, how did this happen on 4 different branches in one week after not happening for six months?
Whiteboard: [orange]
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → khuey
Status: REOPENED → ASSIGNED
Attachment #693118 - Flags: review?(bent.mozilla)
Attached patch PatchSplinter Review
With some changes bent requested.
Attachment #693118 - Attachment is obsolete: true
Attachment #693118 - Flags: review?(bzbarsky)
Attachment #693118 - Flags: review?(bent.mozilla)
Attachment #693130 - Flags: review?(bent.mozilla)
Comment on attachment 693130 [details] [diff] [review]
Patch

Review of attachment 693130 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/OpenDatabaseHelper.cpp
@@ +1520,5 @@
> +        NS_ASSERTION(manager, "Huh?");
> +        manager->AbortCloseDatabasesForWindow(owner);
> +
> +        NS_ASSERTION(database->IsClosed(),
> +                     "Kicking doc out of bfcache should have closed database");

Nit: copy-pasta assertion text is wrong.
Attachment #693130 - Flags: review?(bent.mozilla) → review+
Comment on attachment 693130 [details] [diff] [review]
Patch

I guess this is better than action-at-a-distance via having nsIDocument::Sanitize() just return failure if bfcaching is prevented, yeah.  r=me with the assert fixed.
Attachment #693130 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/d26d10291800
https://hg.mozilla.org/mozilla-central/rev/e7efeccbef31
Status: ASSIGNED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Kyle, is this safe to uplift to Aurora?
Comment on attachment 693130 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: Intermittent orange.
Testing completed (on m-c, etc.): Landed on mozilla-central, baked for a few days.
Risk to taking this patch (and alternatives if risky): Very low risk.
String or UUID changes made by this patch: N/A
Attachment #693130 - Flags: approval-mozilla-aurora?
Comment on attachment 693130 [details] [diff] [review]
Patch

helps fix an intermittent orange, very low risk. Approving on aurora.
Attachment #693130 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
seems its back 18135 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_bfcache.html | Test timed out.

https://tbpl.mozilla.org/php/getParsedLog.php?id=25254948&tree=Mozilla-B2g18
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Carsten Book [:Tomcat] from comment #117)
> seems its back 18135 ERROR TEST-UNEXPECTED-FAIL |
> /tests/dom/indexedDB/test/test_bfcache.html | Test timed out.
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=25254948&tree=Mozilla-B2g18

That's because you didn't read the bug.  This was fixed in 20 and backported to 19.  It never landed on 18.  And that log is from Gecko 18.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Depends on: 1038373
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.