Closed Bug 6966 Opened 21 years ago Closed 20 years ago

'font-family: Georgia, serif' on headings gives Verdana

Categories

(Core :: Internationalization, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: Antti.Nayha, Assigned: erik)

References

()

Details

(Keywords: fonts, Whiteboard: [MAKINGTEST] jrsyrose@writeme.com (py8ieh:should check it still happens))

I'm using build 1999052308 on Win98. Georgia font is *not* installed on my
system.  Therefore, the third heading on the page should be in some serif font
(Times New Roman by default), but in Mozilla it seems to be Verdana.  The
problem is identical in viewer and apprunner.

Might be related (or even duplicate) to #582, #4235 and/or #5861.
Assignee: peterl → ftang
Component: Style System → Internationalization
The correct font name information is hitting the font code. The font system is
returning the wrong font.
Who owns font code these days? Assigning to intl folks as a best guess.
QA Contact: 4110 → 3851
Assignee: ftang → erik
Target Milestone: M11
reassign thsi to erik and target M11
Status: NEW → ASSIGNED
Target Milestone: M11 → M10
Blocks: 7228
Target Milestone: M10 → M12
The problem is still there on M10 Apprunner / WinNT4+SP5.
(Although the third heading is now Arial instead of Verdana.)

#582 and #5861 aren't obviously related, after all.
Target Milestone: M12 → M16
Post-beta, per bobj/erik.
Moving all M16s to M17. Please make comments if you disagree.
Target Milestone: M16 → M17
Whiteboard: [MAKINGTEST] jrsyrose@writeme.com
Whiteboard: [MAKINGTEST] jrsyrose@writeme.com → [MAKINGTEST] jrsyrose@writeme.com (py8ieh:should check it still happens)
Prioritizing my bugs. This one is now M19.
Target Milestone: M17 → M19
I cannot see the problem anymore on build 2000-07-29-08 (WinNT4 SP6a).  I'll
still test on Win98 before marking Worksforme.
Yep, the 2000-07-29-08 build is fine on Win98 too.  Marking Resolved/Worksforme.
Severity: major → normal
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Keywords: fonts
Resolution: --- → WORKSFORME
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.