Windows Ru fails in bidi/613149-2a.html and bidi/613149-2b.html

RESOLVED FIXED in mozilla21

Status

()

defect
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: philor, Assigned: jrmuizel)

Tracking

({intermittent-failure})

Trunk
mozilla21
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Posted file reftests log
https://tbpl.mozilla.org/php/getParsedLog.php?id=6998608&tree=Try#error4
Rev3 WINNT 6.1 try opt test reftest-no-accel on 2011-10-23 12:40:15 PDT for push 0bc26dc49c94

REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2a.html | 966 / 7148 (13%)
REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2-ref.html | 966 / 7148 (13%)
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2a.html | image comparison (==)
...
REFTEST number of differing pixels: 1
REFTEST INFO | Saved log: START file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2a.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Saved log: START file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2-ref.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired

REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2b.html | 967 / 7148 (13%)
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2b.html | image comparison (==)
...
REFTEST number of differing pixels: 1
REFTEST INFO | Saved log: START file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bidi/613149-2b.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
This currently fails on unaccelerated gdi because in the reference we render all of the text in one call which causes the blending of the overlap between the ':' and the 'M' to be different than if we render the strings in two steps. Increasing the font size makes it so that the space between characters is large enough to avoid this problem.
Attachment #571096 - Flags: review?(smontagu)
Comment on attachment 571096 [details] [diff] [review]
Use a larger font size in the reftests

Review of attachment 571096 [details] [diff] [review]:
-----------------------------------------------------------------

If changing font size is sufficient to fix bug 696671 and 696673, r=me for them too.
Attachment #571096 - Flags: review?(smontagu) → review+
https://hg.mozilla.org/mozilla-central/rev/b455a7838d6d
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
The parent for that last one was mozilla-central yesterday afternoon, so it doesn't really seem very fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Annotated as failing in https://hg.mozilla.org/integration/mozilla-inbound/rev/196ede3d3505
Whiteboard: [orange] → [orange][please leave open]
Whiteboard: [orange][please leave open] → [orange]
Target Milestone: mozilla10 → ---
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [orange] → [orange][annotated as fails-if for Win Ru]
Whiteboard: [orange][annotated as fails-if for Win Ru] → [annotated as fails-if for Win Ru]
Switched to fuzzy-if in https://hg.mozilla.org/mozilla-central/rev/5a9d2dcce8ab
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [annotated as fails-if for Win Ru]
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.