crash edocs::CBitmapImage::InitializeGdiPlusPalette , Browser crashes when print a page on Windows XP using 'Microsoft XPS Document Writer'

RESOLVED WORKSFORME

Status

()

Core
General
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

10 Branch
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-d5a83319-e6b0-4208-9f94-c33522111024 .
============================================================= 

Print a page on Windows using the 'Microsoft XPS Document Writer'.
The browser crashes,

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Open any page (ex http://support.mozilla.com/en-US/home )
3. File > Print > Microsoft XPS Document Writer
4. OK , Select File > Save

Actual Results:
  Crashes

Expected Results:
  Not crash



Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/1ca405a46f21
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1 ID:20111011110456
Crashes:
http://hg.mozilla.org/mozilla-central/rev/e0ae39a3298e
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111012 Firefox/10.0a1 ID:20111012031018
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ca405a46f21&tochange=e0ae39a3298e


Regression window(m-i)
Works;
http://hg.mozilla.org/integration/mozilla-inbound/rev/5676f1cc52c8
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1 ID:20111011085356
Crashes:
http://hg.mozilla.org/integration/mozilla-inbound/rev/49ccbc7fd631
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1 ID:20111011091255
Pushlog;
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5676f1cc52c8&tochange=49ccbc7fd631
(Reporter)

Updated

6 years ago
Blocks: 677797
Component: General → General
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Updated

6 years ago
Summary: crash edocs::CBitmapImage::InitializeGdiPlusPalette → crash edocs::CBitmapImage::InitializeGdiPlusPalette , Browser crashes when print a page on Windows XP using 'Microsoft XPS Document Writer'
I've backed out bug 677797.  Can you please test tomorrow's nightly to see whether this is fixed?  Also, can you please let us know the version of Office that you have installed (the XPS Document Writer printer comes with Office, right?).

Thanks!
(Reporter)

Comment 2

6 years ago
I think the printer comes from .NET Framework 3.0.(I have never installed Office)
Snippet of test peint is as follows.

プリンタ名(printer name):Microsoft XPS Document Writer
ドライバ名(driver name):mxdwdrv.dll
データ ファイル(data name):mxdwdui.gpd
構成ファイル(makeup? file):unidrvui.dll
ヘルプ ファイル(help file):unidrv.hlp
ドライバのバージョン(driver version):6.00
環境(env):Windows NT x86
既定のデータ型(default data format):RAW  

このドライバが使う追加ファイル(additional file): 
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\mxdwdui.dll(6.0.6002.22136   (vistasp2_ldr.090513-2347))
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\mxdwdui.ini
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\stddtype.gdl
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\stdnames.gpd
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\stdschem.gdl
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\stdschmx.gdl
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\unidrv.dll(6.0.6002.22136   (vistasp2_ldr.090513-2347))
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\unires.dll(6.0.6002.22136   (vistasp2_ldr.090513-2347))
C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\XpsSvcs.dll(6.0.6002.22136   (vistasp2_ldr.090513-2347))
(Reporter)

Comment 3

6 years ago
works for me on today's Nightly .
http://hg.mozilla.org/mozilla-central/rev/cc66accc8181
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111026 Firefox/10.0a1 ID:20111026031017

And I conform that the following cset foxed the crash.
http://hg.mozilla.org/mozilla-central/rev/ddaf5686c70c
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025083546
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 4

6 years ago
Maybe this was caused by one of the dll's loaded here having a hardcoded location, so therefore to implement mandatory aslr we would need to blacklist this.
Blocks: 728429
No longer blocks: 728429
You need to log in before you can comment on or make changes to this bug.