Last Comment Bug 696876 - Rename class CodeGenerator to BytecodeEmitter
: Rename class CodeGenerator to BytecodeEmitter
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Jason Orendorff [:jorendorff]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 14:07 PDT by Jason Orendorff [:jorendorff]
Modified: 2011-10-28 04:35 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1 - Rename js::CodeGenerator to js::BytecodeEmitter, v1 (361.84 KB, patch)
2011-10-24 14:08 PDT, Jason Orendorff [:jorendorff]
dvander: review+
Details | Diff | Review
Part 2 - Change CG_ macros to BytecodeEmitter methods, v1 (95.09 KB, patch)
2011-10-24 14:12 PDT, Jason Orendorff [:jorendorff]
dvander: review+
Details | Diff | Review
Part 3 - Rename PopStatementCG and NewScriptFromCG (17.79 KB, patch)
2011-10-24 14:19 PDT, Jason Orendorff [:jorendorff]
dvander: review+
Details | Diff | Review

Description Jason Orendorff [:jorendorff] 2011-10-24 14:07:13 PDT
Recently I renamed JSCodeGenerator to js::CodeGenerator. This caused it to be impossible to merge tip to IonMonkey, because IM has a class CodeGenerator of its own.

So let's try BytecodeEmitter.

This patch is big mostly because the almost universal name for variables of type CodeGenerator* is "cg".

Taking the opportunity to change CodeGenerator macros to methods.
Comment 1 Jason Orendorff [:jorendorff] 2011-10-24 14:08:51 PDT
Created attachment 569178 [details] [diff] [review]
Part 1 - Rename js::CodeGenerator to js::BytecodeEmitter, v1
Comment 2 Jason Orendorff [:jorendorff] 2011-10-24 14:12:53 PDT
Created attachment 569179 [details] [diff] [review]
Part 2 - Change CG_ macros to BytecodeEmitter methods, v1
Comment 3 Jason Orendorff [:jorendorff] 2011-10-24 14:19:58 PDT
Created attachment 569182 [details] [diff] [review]
Part 3 - Rename PopStatementCG and NewScriptFromCG
Comment 4 David Anderson [:dvander] 2011-10-24 16:36:15 PDT
Comment on attachment 569179 [details] [diff] [review]
Part 2 - Change CG_ macros to BytecodeEmitter methods, v1

Review of attachment 569179 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.

Note You need to log in before you can comment on or make changes to this bug.