If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Create test updates for suppressing/not suppressing the What's New page

VERIFIED FIXED

Status

Release Engineering
General
P2
critical
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
For Firefox 8, the Product team have asked that the What's New page shown after the update is applied be suppressed. Work to support that has happened in bug 459972 (AUS server) and bug 682805 (update generation), and we need to do some testing asap before 8.0 final comes along.

The What's New page isn't shown on updates from one beta to another, because the code looks for milestone changes and all the 8.0 betas are '8.0'. So we need a test path from the builds on the release channel to 8.0b4 with the special sauce in the snippets (ie actions=silent). (echnically we could use 7.0 and older betas, but lets test what the end users have.
(Assignee)

Comment 1

6 years ago
Created attachment 569312 [details]
Patcher config

This is a fusion of the mozRelease-branch-patcher2.cfg with the <8.0b4> block from the beta config, 'actions   silent' and 'schema   2' added the current update. Run against the patches from bug 682805 run in a staging environment. I haven't generated any partials from 7.0.1 to 8.0b4, to speed things up a bit.

Snippets are staged at Firefox-8.0b4-build1-suppressWhatsNew-test in the usual location. Waiting on the nightly backup to complete before pushing and verifying.
CCing Mihaela as QA Owner of What's New page
(Assignee)

Comment 3

6 years ago
The update path is available:
* Starting with a release builds: 4.0, 4.0.1, 5.0, 5.0.1, 6.0, 6.0.1, 6.0.2, 7.0, 7.0.1
* Use the releasetest channel
* You will end up on 8.0b4 (buildID is 20111019081014; or load about:buildconfig, follow the source link and make sure the take is FIREFOX_8_0b4_RELEASE)
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Adding QA+ for verification using comment 3. Nick, I'm assuming if we get to 8.0b5 before we have a chance to test this that the expectation is ending up on 8.0b5, right?

Mihaela, please do some testing to verify this fix. I don't recommend testing all of the update paths, but try to achieve at least 50%.

Thanks
Whiteboard: [qa+]
(Assignee)

Comment 5

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #4)
> Nick, I'm assuming if we get to
> 8.0b5 before we have a chance to test this that the expectation is ending up
> on 8.0b5, right?

No, I'd have to regenerate the update path for that. I'm not sure it's worth it because what we want to check is that
* the update is found and works with all these new attributes being set
* the what's new page isn't shown after restart

The actual destination build isn't critical AFAIK.
I verified some update paths on all platforms using steps form comment #3 and they worked as expected (as described in comment #5): update was successful and what's new page wasn't shown after restart.
I would also need to verify some updates with what's new page enabled (using the new attributes) to make sure functionality didn't break.
(Assignee)

Comment 7

6 years ago
(In reply to Mihaela Velimiroviciu [QA] from comment #6)
> I verified some update paths on all platforms using steps form comment #3
> and they worked as expected (as described in comment #5): update was
> successful and what's new page wasn't shown after restart.

Great!

> I would also need to verify some updates with what's new page enabled (using
> the new attributes) to make sure functionality didn't break.

I'll set that up ...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Create a test update for suppressing the What's New page → Create test updates for suppressing/not suppressing the What's New page
(Assignee)

Comment 8

6 years ago
Mihaela, I've modified the update path we already had. The details in comment #3 are still correct, the only change should be showing the What's New after the update is applied.

-----------
Details for RelEng:

cd /opt/aus2/snippets/staging
rsync -a old/Firefox-8.0b4-build1-suppressWhatsNew-test/ \
             Firefox-8.0b4-build1-showWhatsNew-test/

cd Firefox-8.0b4-build1-showWhatsNew-test/
find . -type f -print -exec sed -i -e 's/^actions.*$//' {} \;

~/bin/backupsnip Firefox-8.0b4-build1-showWhatsNew-test
~/bin/pushsnip   Firefox-8.0b4-build1-showWhatsNew-test
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Verified updates in different combinations of released builds (4.0...7.0.1) and OSs with the new setup and they worked fine:
* update was found and finished successfully
* what's new page was shown at restart

Changing status to VERIFIED.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
(Assignee)

Comment 10

6 years ago
Thanks Mihaela!
We'll have to retest this once we get RC builds, on all test update channels since the behavior can be affected by channel.
I've retested updates on "betatest" channel, from released builds (4.0, ..., 7.0.1). The update (Firefox 8 RELEASE) was found and installed correctly. What's new page was not displayed at restart.

Are there any other test update channels to test (except betatest and releasetest)?
I've also run some quick tests on release and beta channels and they seem to work fine.
On release, version was updated to Firefox 7.0.1 (from a version lower than 7) and what's new page was not displayed.
On beta, version was updated to 8beta6 (from a version lower than 8) and what's new page was not displayed.
Thanks Mihaela, I can confirm your results:

During the beta update testing, going from older builds to Fx8b6(build2), the "what's new page" was suppressed.

Today, I tested current update offers on releasetest going from previous versions to Fx8RC and in all cases the "what's new" page was suppressed. This is what is going out tomorrow for the final release.
(Assignee)

Comment 15

6 years ago
I'd like to clarify a couple of things here, with zero intention of undermining our readiness to ship Fx8. We're fine for that based on the checks done.

(In reply to Mihaela Velimiroviciu [QA] from comment #13)
> On release, version was updated to Firefox 7.0.1 (from a version lower than
> 7) and what's new page was not displayed.

This is because Fx7 didn't show any what's new at all, rather than magic in the snippets. We can stop remembering that special case tomorrow, when we no longer point any updates at 7.0.x.

(In reply to juan becerra [:juanb] from comment #14)
> During the beta update testing, going from older builds to Fx8b6(build2),
> the "what's new page" was suppressed.

8.0bN -> 8.0b6 won't show a what's new, regardless of what's in the snippet, because the version isn't changing (8.0 for all betas). If you did 7.0bN or older -> 8.0b6 then suppressing what's new is due to the snippet.

Thanks everyone!
(In reply to Nick Thomas [:nthomas] from comment #15)
> I'd like to clarify a couple of things here, with zero intention of
> undermining our readiness to ship Fx8. We're fine for that based on the
> checks done.
> 
> (In reply to Mihaela Velimiroviciu [QA] from comment #13)
> > On release, version was updated to Firefox 7.0.1 (from a version lower than
> > 7) and what's new page was not displayed.
> 
> This is because Fx7 didn't show any what's new at all, rather than magic in
> the snippets. We can stop remembering that special case tomorrow, when we no
> longer point any updates at 7.0.x.
> 
> (In reply to juan becerra [:juanb] from comment #14)
> > During the beta update testing, going from older builds to Fx8b6(build2),
> > the "what's new page" was suppressed.
> 
> 8.0bN -> 8.0b6 won't show a what's new, regardless of what's in the snippet,
> because the version isn't changing (8.0 for all betas). If you did 7.0bN or
> older -> 8.0b6 then suppressing what's new is due to the snippet.
> 

The latter was done from 5, 6, and 7 betaX to Fx8RC. I didn't check 8bX->8RC.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.