Last Comment Bug 697085 - Link to mac malloc headers in memory/jemalloc/osx_zone_types.h
: Link to mac malloc headers in memory/jemalloc/osx_zone_types.h
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Memory Allocator (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Justin Lebar (not reading bugmail)
:
: Mike Hommey [:glandium]
Mentors:
Depends on: 603655
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 06:59 PDT by Justin Lebar (not reading bugmail)
Modified: 2012-02-01 13:16 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch v1 (1.19 KB, patch)
2011-10-25 07:07 PDT, Justin Lebar (not reading bugmail)
gerv: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2011-10-25 06:59:11 PDT
Per bug 603655 comment 17, we should link to apple's malloc.h from memory/jemalloc/osx_zone_types.h, since that file properly documents the structs' members.

http://www.opensource.apple.com/source/Libc/Libc-763.12/include/malloc/malloc.h
Comment 1 Justin Lebar (not reading bugmail) 2011-10-25 07:07:20 PDT
Created attachment 569354 [details] [diff] [review]
Patch v1
Comment 2 Justin Lebar (not reading bugmail) 2011-11-20 18:21:30 PST
Thanks, gerv.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f3be04c268c9
Comment 3 Matt Brubeck (:mbrubeck) 2011-11-21 09:03:43 PST
https://hg.mozilla.org/mozilla-central/rev/f3be04c268c9

Note You need to log in before you can comment on or make changes to this bug.