Last Comment Bug 697087 - Multiple notifications content permission prompt
: Multiple notifications content permission prompt
Status: VERIFIED FIXED
: feature
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Gian-Carlo Pascutto [:gcp]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 694672
  Show dependency treegraph
 
Reported: 2011-10-25 07:01 PDT by Aaron Train [:aaronmt]
Modified: 2012-01-10 11:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Nightly (10/25) (180.88 KB, image/png)
2011-10-25 07:01 PDT, Aaron Train [:aaronmt]
no flags Details
Multiple prompts (51.68 KB, image/png)
2011-10-25 07:11 PDT, Aaron Train [:aaronmt]
no flags Details
Patch 1. Replace repeated requests (3.13 KB, patch)
2011-11-01 12:02 PDT, Gian-Carlo Pascutto [:gcp]
mark.finkle: review+
Details | Diff | Splinter Review
Patch 1. v2 Replace repeated requests (6.96 KB, patch)
2011-11-01 12:47 PDT, Gian-Carlo Pascutto [:gcp]
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-10-25 07:01:01 PDT
Created attachment 569353 [details]
Nightly (10/25)

See screenshot.

--
Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111025 Firefox/10.0a1
Samsung Galaxy SII (Android 2.3.4)
Comment 1 Aaron Train [:aaronmt] 2011-10-25 07:11:57 PDT
Created attachment 569355 [details]
Multiple prompts

STR: 
1. http://html5demos.com/geo
2. Reload page multiple times
Comment 2 Gian-Carlo Pascutto [:gcp] 2011-11-01 12:02:25 PDT
Created attachment 571090 [details] [diff] [review]
Patch 1. Replace repeated requests
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-01 12:11:07 PDT
Comment on attachment 571090 [details] [diff] [review]
Patch 1. Replace repeated requests

Checking for dupes based on the message text isn't the best way. In XUL we give each notification a value or tag, making it easier to match when checking for dupes.

This is incrementally better than what we currently have. I guess we can go with this patch for now, but I think we should file a new bug to switch to use value/tag.

https://developer.mozilla.org/en/XUL/notificationbox  (look for 'value')
Comment 4 Gian-Carlo Pascutto [:gcp] 2011-11-01 12:47:28 PDT
Created attachment 571112 [details] [diff] [review]
Patch 1. v2 Replace repeated requests

This should be a more proper fix.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-01 12:52:37 PDT
Comment on attachment 571112 [details] [diff] [review]
Patch 1. v2 Replace repeated requests

Great! Thanks
Comment 6 Gian-Carlo Pascutto [:gcp] 2011-11-01 13:38:04 PDT
http://hg.mozilla.org/projects/birch/rev/2b9de9749c1e
Comment 7 Aaron Train [:aaronmt] 2011-11-02 06:35:51 PDT
20111102040257
http://hg.mozilla.org/projects/birch/rev/2b9de9749c1e
Samsung Nexus S (Android 2.3.6)

Note You need to log in before you can comment on or make changes to this bug.