Last Comment Bug 697102 - Fix a typo in xpcom/base/nsIErrorService.idl
: Fix a typo in xpcom/base/nsIErrorService.idl
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla10
Assigned To: ISHIKAWA, Chiaki
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 07:34 PDT by ISHIKAWA, Chiaki
Modified: 2011-11-01 07:34 PDT (History)
2 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix a typo in xpcom/base/nsIErrorService.idl (814 bytes, patch)
2011-10-25 07:34 PDT, ISHIKAWA, Chiaki
benjamin: review+
Details | Diff | Splinter Review
The patch in requested format (username, comment, et.) (710 bytes, patch)
2011-10-31 10:03 PDT, ISHIKAWA, Chiaki
ishikawa: review+
emorley: checkin+
Details | Diff | Splinter Review

Description ISHIKAWA, Chiaki 2011-10-25 07:34:56 PDT
Created attachment 569365 [details] [diff] [review]
Fix a typo in xpcom/base/nsIErrorService.idl

There is a simple typo in the comment in xpcom/base/nsIErrorService.idl, which
is very confusing.

It should be fixed.
Comment 1 Ed Morley [:emorley] 2011-10-28 03:47:12 PDT
Please could you tweak your hgrc to automatically add author info (guide here: http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed) + add a commit message when attaching patches, since it makes pushing half a dozen checkin-neededs a lot easier. Thanks :-)
Comment 2 ISHIKAWA, Chiaki 2011-10-31 10:03:54 PDT
Created attachment 570745 [details] [diff] [review]
The patch in requested format (username, comment, et.)

I re-created the patch in requested format with Username, and check in message.
I tried to use so called "Mercurial Queues", but being a relative newbie to `hg' itself, I bumbled and so the attached patch is actually a part of
a larger patchset that includes a host of other changes in other files.
(I didn't realize Mercurial Queues tries to incorporate all the changes in hg repository as one. I read the explanation in https://developer.mozilla.org/en/Mercurial_Queues  to mean that a set of files under "one directory" be handled as part of patchset creation, but no it is under "one repository".
Oh well.

Please let me know if the file attached looks to be in the format you expect.
Comment 3 ISHIKAWA, Chiaki 2011-10-31 10:04:45 PDT
(In reply to Ed Morley [:edmorley] from comment #1)
> Please could you tweak your hgrc to automatically add author info (guide
> here:
> http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed) +
> add a commit message when attaching patches, since it makes pushing half a
> dozen checkin-neededs a lot easier. Thanks :-)

See comment 2

TIA
Comment 4 Ed Morley [:emorley] 2011-10-31 11:07:36 PDT
Comment on attachment 570745 [details] [diff] [review]
The patch in requested format (username, comment, et.)

Great, thanks :-)

https://hg.mozilla.org/integration/mozilla-inbound/rev/43135d676c68
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-11-01 07:34:21 PDT
https://hg.mozilla.org/mozilla-central/rev/43135d676c68

Note You need to log in before you can comment on or make changes to this bug.