Last Comment Bug 697109 - browser_styleinspector_webconsole.js sometimes fails with instance stylePanels[1] is hidden
: browser_styleinspector_webconsole.js sometimes fails with instance stylePanel...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: P2 normal (vote)
: Firefox 10
Assigned To: Rob Campbell [:rc] (:robcee)
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 07:53 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-10-27 11:36 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testfix (1.05 KB, patch)
2011-10-25 08:24 PDT, Rob Campbell [:rc] (:robcee)
mihai.sucan: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-10-25 07:53:02 PDT
Fallout from landing bug 685893, this test can fail on faster machines due to the panel being scavenged by the destructor method.
Comment 1 Rob Campbell [:rc] (:robcee) 2011-10-25 08:24:50 PDT
Created attachment 569381 [details] [diff] [review]
testfix
Comment 2 Mihai Sucan [:msucan] 2011-10-25 08:49:50 PDT
Comment on attachment 569381 [details] [diff] [review]
testfix

Review of attachment 569381 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Thanks!
Comment 3 Rob Campbell [:rc] (:robcee) 2011-10-25 09:17:25 PDT
https://hg.mozilla.org/integration/fx-team/rev/2a901edc04a9
Comment 4 :Margaret Leibovic 2011-10-27 11:36:00 PDT
https://hg.mozilla.org/mozilla-central/rev/2a901edc04a9

Note You need to log in before you can comment on or make changes to this bug.