Last Comment Bug 697282 - IonMonkey: Support JSOP_CALLPROP
: IonMonkey: Support JSOP_CALLPROP
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 684381
  Show dependency treegraph
 
Reported: 2011-10-25 15:20 PDT by Stephan Herhut [:masterofhats]
Modified: 2012-01-10 16:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
method.js (183 bytes, text/plain)
2011-10-25 15:20 PDT, Stephan Herhut [:masterofhats]
no flags Details
Handle JSOP_CALLPROP as JSOP_GETPROP. (465 bytes, patch)
2012-01-10 15:28 PST, Sean Stangl [:sstangl]
dvander: review+
Details | Diff | Splinter Review
Handle JSOP_CALLPROP as JSOP_GETPROP, v2 (901 bytes, patch)
2012-01-10 15:59 PST, Sean Stangl [:sstangl]
dvander: review+
Details | Diff | Splinter Review

Description Stephan Herhut [:masterofhats] 2011-10-25 15:20:04 PDT
Created attachment 569523 [details]
method.js

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E; MS-RTC LM 8)

Steps to reproduce:

I executed the attached js, which essentially calls an object's method, using the js shell:

js --ion --ion-eager mehtod.js


Actual results:

I got

[MIR] Analying script js-samples/method.js:8
[Abort] Unsupported opcode: callprop (line 9)


Expected results:

IonMonkey should have compiled the function and the contained method call.
Comment 1 Sean Stangl [:sstangl] 2011-11-01 14:06:17 PDT
This is expected behavior, since IonMonkey is still in the early stages, and there are many things we haven't yet implemented. We don't even support calling global functions yet (bug 694169). This also depends on us supporting JSOP_GETPROP.

I've renamed the bug so that we can get back to it once we're at that point.
Comment 2 Sean Stangl [:sstangl] 2012-01-10 15:28:26 PST
Created attachment 587510 [details] [diff] [review]
Handle JSOP_CALLPROP as JSOP_GETPROP.

With Bug 712714 resolved in-tree, JSOP_CALLPROP is the same as JSOP_GETPROP.
Comment 3 Sean Stangl [:sstangl] 2012-01-10 15:59:59 PST
Created attachment 587522 [details] [diff] [review]
Handle JSOP_CALLPROP as JSOP_GETPROP, v2

JSOP_SWAP needs to be followed by JSOP_NOTEARG in the context of JSOP_CALLPROP.
Comment 4 Sean Stangl [:sstangl] 2012-01-10 16:24:52 PST
http://hg.mozilla.org/projects/ionmonkey/rev/d601339c1bea

Note You need to log in before you can comment on or make changes to this bug.