Incorrect error page, "File not found" during internal server error with non-html/non-text mime types

RESOLVED DUPLICATE of bug 426961

Status

()

--
trivial
RESOLVED DUPLICATE of bug 426961
7 years ago
7 years ago

People

(Reporter: jack, Unassigned)

Tracking

10 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111024 Firefox/10.0a1
Build ID: 20111024031040

Steps to reproduce:

I experienced some server error. That is not firefox's problem, but take a look at what it did with these headers (viewed/copied from livehttpheaders add-on):

HTTP/1.1 500 Internal Server Error
Date: Tue, 25 Oct 2011 21:54:41 GMT
Server: Apache/2.0.52 (Red Hat)
server-error: true
Content-Language: en-US
Connection: close
Transfer-Encoding: chunked
Content-Type: application/x-vnd.ms-excel




Actual results:

Firefox showed the built in  "File not found" page, which would seem to indicate a 404, and perhaps I should try a different request.

----------
File not found
          Firefox can't find the file at https://( ... ).

  Check the file name for capitalization or other typing errors.
  Check to see if the file was moved, renamed or deleted.
----------


Expected results:

It should have said "Internal Server Error" somewhere. The difference between a 4xx and 5xx error affects user expectations/behavior, so I don't think we should show one in place of the other.

I can't think of a good reason it would say "File not found."  If the mime header had something viewable in firefox, like "text/html", then we'd have seen the text accompanying the server error (whether that be useful or not), but in this case, firefox goes to the trouble of producing an error page that misrepresents the situation. THe "File not found" doesn't give the impression that server operator attention might be required (assuming the operator is looking, or the user has a way of contacting the operator), or that a user might be able to try again successfully, later, after the server problem is fixed.
(Reporter)

Updated

7 years ago
Severity: normal → trivial
(Reporter)

Comment 1

7 years ago
For some reason 426961 didn't come up in my searches for "file not found". Sorry for the spam.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426961
You need to log in before you can comment on or make changes to this bug.