Add DuckDuckGo to search engine list.

RESOLVED DUPLICATE of bug 1061736

Status

()

enhancement
RESOLVED DUPLICATE of bug 1061736
8 years ago
5 years ago

People

(Reporter: caine, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The attached patch adds DuckDuckGo to the default search toolbar list.
Additionally I have built this against trunk to ensure it works.  The test system was Mac OS X 10.7.2.  "uname -a" reports: Darwin dax.duckduckgo.com 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hello, I work at DuckDuckGo and was wondering:

1) what's the process to get added to Firefox?
2) When we can get added to Firefox/ 

Thanks!
Asa, would you know the answer to comment 3?
Flags: needinfo?(asa)
(In reply to Prakash S from comment #3)
> Hello, I work at DuckDuckGo and was wondering:
> 
> 1) what's the process to get added to Firefox?

The process is to convince me that your addition to the list ads significant value to the user experience.

> 2) When we can get added to Firefox/ 

I've met with the DDG team and continue to follow DDG developments. I've been studying search very closely with our user research team and considering some changes there. 

Adding another general category search, one that's not in high demand and which has very low usage share, is not in my plans for Firefox right now.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(asa)
Resolution: --- → WONTFIX
Hey Asa, this is Gabriel Weinberg (founder of DuckDuckGo). We appreciate how much you care about your user experience and thank you for meeting with us and following our efforts. We believe DuckDuckGo does add significant value to the Firefox user experience and our addition is warranted because of that value.

We would be the only search engine in that list that does not collect or store personal information by default (https://duckduckgo.com/privacy/).  

There are several additional things that make us significantly different like our open source instant answer platform, our much more aggressive stance at removing content farms, our different look and feel, etc.  However, even putting all those additions aside, giving users the simple option of searching with an engine that (really) does not track them is alone a meaningful addition.
I wanted to weigh in on this. Adding DuckDuckGo could actually be users' first exposure to information about tracking and bubbling. I cannot express how much I would love to see this as an option in Firefox. In fact, the majority of my friends use DuckDuckGo, and have expressed some frustration in enabling it in Firefox.
As privacy has become a wider user's focus since Edward Snowden's leaks about the NSA and GHCQ attacking user's privacy by tracking as much internet traffic as they can mozilla should at least one privacy focused search engine like DDG or Startpage. These search engines try to save as less informations about their users as possible and IMHO only informations which are saved nowhere are safe informations.
FYI, Apple decided to include DuckDuckGo in Safari two months ago:

https://duck.co/blog/safari
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1061736
You need to log in before you can comment on or make changes to this bug.