startup cache returns buffers inconsistently allocated

RESOLVED DUPLICATE of bug 684700

Status

()

defect
RESOLVED DUPLICATE of bug 684700
8 years ago
8 years ago

People

(Reporter: enndeakin, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
Comment from bug 94199.

StartupCache::GetBuffer sometimes returns a buffer allocated with new[] and sometimes (via zipItem.Forget()) a buffer allocated with malloc. zipItems themselves are also doing this.
This was already filed as bug 684700 ("StartupCache::GetBuffer needs to clarify how the returned buffer was allocated").
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684700
You need to log in before you can comment on or make changes to this bug.