GLContext initializer list out of order (warning: ‘mozilla::gl::GLContext::mOffscreenReadFBO’ will be initialized after ... ‘bool mozilla::gl::GLContext::mOffscreenFBOsDirty’)

RESOLVED DUPLICATE of bug 615976

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 615976
7 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Filing bug on this build warning, which (based on hg blame) looks to have been introduced by bug 615976 ( http://hg.mozilla.org/mozilla-central/rev/941b7fe14983 ):

> In constructor ‘mozilla::gl::GLContext::GLContext(const mozilla::gl::ContextFormat&, bool, mozilla::gl::GLContext*)’:
> GLContext.h:1340:12: warning: ‘mozilla::gl::GLContext::mOffscreenReadFBO’ will be initialized after
> GLContext.h:864:10: warning:   ‘bool mozilla::gl::GLContext::mOffscreenFBOsDirty’
> GLContext.h:532:5: warning:   when initialized here

This is hit for every file that includes GLContext.h, so this prints out a good deal of spam.

Jeff, wanna take this?  Should just need to reorder the affected lines of the constructor's init list, to match the member-variables' order in the .h file.
Fixed in the follow-up patch to bug 615976, which just landed on inbound today.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615976
You need to log in before you can comment on or make changes to this bug.