Build warning: WebGLContext.cpp:557:10: warning: unused variable ‘preferOpenGL’

RESOLVED DUPLICATE of bug 711799

Status

()

defect
RESOLVED DUPLICATE of bug 711799
8 years ago
8 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

I get this build warning on linux:
> WebGLContext.cpp:557:10: warning: unused variable ‘preferOpenGL’

It looks like the variable is declared unconditionally, but is only used #ifdef XP_WIN.
http://mxr.mozilla.org/mozilla-central/source/content/canvas/src/WebGLContext.cpp#557
http://mxr.mozilla.org/mozilla-central/source/content/canvas/src/WebGLContext.cpp?mark=651-651#649

Perhaps we should shift this variable down to be inside the XP_WIN chunk where it's used?  (or, leave it where it is, but wrap it in #ifdefs?)
This was fixed as part of bug 711799.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711799
You need to log in before you can comment on or make changes to this bug.