Closed Bug 697555 Opened 11 years ago Closed 11 years ago

when turning on responsiveness for tp5, the browser hangs or crashes

Categories

(Testing :: Talos, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(2 files)

On osx 10.5.8 and 10.6.2 we fail to terminate the browser after completing the tp5 test.  Similarly on Fedora 12, we end up crashing.


linux:
https://tbpl.mozilla.org/php/getParsedLog.php?id=7041789&tree=Mozilla-Inbound

10.6.2:
https://tbpl.mozilla.org/php/getParsedLog.php?id=7040940&tree=Mozilla-Beta

10.5.8:
https://tbpl.mozilla.org/php/getParsedLog.php?id=7041676&tree=Mozilla-Aurora
so it seems as though similar symptoms exist without this, just much more infrequently:
https://bugzilla.mozilla.org/show_bug.cgi?id=664371
ok, I just realized that the OSX failures were on aurora/beta which do not have the fix that ted landed.
this will allow us to control responsiveness via the commandline from buildbot.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #572115 - Flags: review?(jhammel)
Comment on attachment 572115 [details] [diff] [review]
allow for responsiveness to be controlled by a commandline flag (1.0)

+            if self.responsiveness and ('responsiveness' in line):
+                newline = line.replace('False', 'True')
+

I don't really like this as it tightly couples the format of the file with the PerfConfigurator.  Old news, I know.  That said, this should all be cleaned up so I think its fine for now.
Attachment #572115 - Flags: review?(jhammel) → review+
I think this will fix the OS X issues, but we'll still have the GTK issue, right?
I haven't been able to reproduce the GTK issue.  That could have been a one off error on linux/firefox/tp5 unrelated to this.
Depends on: 702351
since we are seeing some browsers exiting with non zero return codes in our staging environment, lets not run tests on linux until we can figure that out.
Attachment #575186 - Flags: review?(wlachance)
Comment on attachment 575186 [details] [diff] [review]
disable responsiveness for linux (1.0)

+            if 'responsiveness' in test_config and test_config['responsiveness'] and platform.system() != "Linux":

Couldn't you just write this as:

test_config.get('responsiveness') and platform.system() != "Linux":

(same for the one below)

Otherwise, looks fine.
Attachment #575186 - Flags: review?(wlachance) → review+
this has landed and has had a few data points successfully
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
So I notice this comment at http://hg.mozilla.org/build/talos/file/705a12151bf2/talos/ttest.py#l256 :

# ignore responsiveness tests on linux until we fix Bug 697555

Since this bug is now resolved->fixed , should we remove this code block?  Should we reopen this bug for this purpose or file another one?
(In reply to Jeff Hammel [:jhammel] from comment #12)
> So I notice this comment at
> http://hg.mozilla.org/build/talos/file/705a12151bf2/talos/ttest.py#l256 :
> 
> # ignore responsiveness tests on linux until we fix Bug 697555
> 
> Since this bug is now resolved->fixed , should we remove this code block? 
> Should we reopen this bug for this purpose or file another one?

File a new one to turn on responsiveness for linux please.
done: bug 710296
You need to log in before you can comment on or make changes to this bug.