Closed Bug 697611 Opened 10 years ago Closed 10 years ago

release_sanity.py should check in-tree mozconfigs if they exist

Categories

(Release Engineering :: General, defect, P3)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: bhearsum)

References

Details

Attachments

(2 files)

Right now we don't use in-tree mozconfigs for release builds, but once we merge from central to aurora and beta for Firefox 10 we'll be able to. Probably bug 558180 is where that will happen (*sets dependency*).

release_sanity will then need to learn to look at the in-tree mozconfigs to do the comparisons. This is a followup to bug 386338 (*sets blocking*).
No longer blocks: 386338
Depends on: 386338
taking this and changed it to depending on bug 386338 since we needed release_sanity to check mozconfigs at all before we can ask it to check for in-tree or not (as that will be for some branches and not all like mozilla-1.9.2)
Assignee: nobody → lsblakk
Status: NEW → ASSIGNED
Duplicate of this bug: 721044
This caused an error in the 10.0esr release because we don't have buildbot-configs versions of the mozconfigs at all. Any ETA on this?
Testing out this fix in staging:
diff --git a/buildbot-helpers/release_sanity.py b/buildbot-helpers/release_sanity.py
index 300094b..f40eced 100644
--- a/buildbot-helpers/release_sanity.py
+++ b/buildbot-helpers/release_sanity.py
@@ -110,7 +110,7 @@ def verify_mozconfigs(branch, version, hghost, product, platforms, whitelist=Non
         urls = []
         mozconfigs = []
         for type in types.values():
-            urls.append(make_hg_url(hghost, 'build/buildbot-configs', 'http', 
+            urls.append(make_hg_url(hghost, branch, 'http', 
                                 tag, os.path.join('mozilla2', platform, 
                                 branch, type,'mozconfig')))
         for url in urls:
I'm working on a fix for this as part of bug 717106, which suffers from this more acutely.
Assignee: lsblakk → bhearsum
This affects ESR more than other branches, because we don't have a full set of mozconfigs in buildbot-configs. Because of that, I had to find a fix.
Attachment #593287 - Flags: review?(lsblakk)
Comment on attachment 593287 [details] [diff] [review]
use mozconfigs from release config to find in-repo ones to compare

lgtm, thanks for picking this up
Attachment #593287 - Flags: review?(lsblakk) → review+
Attachment #593287 - Flags: checked-in+
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Fennec is a good citizen as well :)

PYTHONPATH=. python ../tools/buildbot-helpers/release_sanity.py -u rail -pfirefox,fennec    -V 10.0b1 --branch mozilla-beta --build-number 1 -c release-firefox-mozilla-beta.py -c release-fennec-mozilla-beta.py    --dryrun  localhost:9001 2>&1 | tee rail.out
(build1)[cltbld@buildbot-master08 master]$  PYTHONPATH=. python ../tools/buildbot-helpers/release_sanity.py -u rail -pfirefox,fennec \
>    -V 11.0b1 --branch mozilla-beta --build-number 1 -c release-firefox-mozilla-beta.py -c release-fennec-mozilla-beta.py \
>    --dryrun  localhost:9001 2>&1 | tee rail.out
Traceback (most recent call last):
  File "../tools/buildbot-helpers/release_sanity.py", line 365, in <module>
    releaseConfig['sourceRepositories']['mozilla']['path'],
KeyError: 'mozilla'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #594206 - Flags: review?(rail) → review+
Attachment #594206 - Flags: checked-in+
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Depends on: 727740
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.