Last Comment Bug 697647 - flicker on html5/webm video
: flicker on html5/webm video
Status: VERIFIED FIXED
[qa!] [verified-beta] [verified-aurora]
: regression
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 8 Branch
: All All
: -- normal (vote)
: mozilla10
Assigned To: Matthew Gregan [:kinetik]
:
:
Mentors:
flim.org/~kinetik/bug697647.html
: 640074 690356 (view as bug list)
Depends on:
Blocks: 630835
  Show dependency treegraph
 
Reported: 2011-10-26 19:59 PDT by Jean-Marc Valin (:jmspeex)
Modified: 2011-12-06 17:53 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected
-
fixed


Attachments
patch v0 (916 bytes, patch)
2011-11-01 22:45 PDT, Matthew Gregan [:kinetik]
roc: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta-
Details | Diff | Splinter Review

Description Jean-Marc Valin (:jmspeex) 2011-10-26 19:59:22 PDT
When viewing the following video on Youtube in *HTML5* mode, I'm getting a black flicker at the bottom of the video:

http://www.youtube.com/watch?v=JzhlfbWBuQ8

Steps to reproduce:

1) Go to http://www.youtube.com/html5/ and enable HTML5 trial

2) Go to http://www.youtube.com/watch?v=JzhlfbWBuQ8

3) Black flicker at the bottom of the video

The problem does not happen with Firefox 7.0.1, but it does happen with the latest Beta of FF 8, as well as with Aurora (FF 9). In Aurora, the "Full screen" button also does not work. The flicker problem does not happen on most other videos I watched and I don't know what's special about this one.

My machine is a Thinkpad W520 (Intel i7), 4 GB RAM, running Debian testing (amd64) with the Intel video driver. I'm running the standard 32-bit FF builds.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-01 17:22:11 PDT
Karl, Matthew, can you reproduce this?
Comment 2 Matthew Gregan [:kinetik] 2011-11-01 18:40:50 PDT
I can reproduce this with the linked video, and I have seen it before on other YouTube hosted WebM videos.

Changing the background colour of the video-container div (which contains the video element) to red changes the colour of the flickr flickering box to red also.

When hovering over the scrubber bar, you can also see a similar flicker around the bubble popup.
Comment 3 Matthew Gregan [:kinetik] 2011-11-01 18:45:32 PDT
I'm also seeing this in the Firefox 7.0.1 release, but it's much worse in the nightlies.
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-01 20:58:44 PDT
I assume GL layers are still disabled by default for Linux?

Sounds like the flicker does not cover the entire video?

Try dumping the GetClipExtents in force when we draw the BasicImageLayer to see if the image is being incorrectly clipped or something?
Comment 5 Matthew Gregan [:kinetik] 2011-11-01 21:18:38 PDT
It's not enabled for me, about:support reports 0/1 accelerated windows.  Minimal testcase (as linked):

<div style="background:#f0f;height:360px">
  <video src="sync240.webm" height="100%"></video>
</div>

Right click the video, select play, then click elsewhere in the document to defocus the video.  If the video is left focused, the bug doesn't occur.  If the video is started via autoplay or the controls, the bug doesn't occur.  The video also seems to need to be scaled up for this to occur.  The size of the flickering box doesn't seem to increase with scaling, and given the size and positioning it's probably related to the hidden default controls.
Comment 6 Matthew Gregan [:kinetik] 2011-11-01 21:36:06 PDT
doublec pointed me to bug 640074 (which I can no longer reproduce locally), but I can't reproduce this bug with prescale always false in gfxUtils::GetYCbCrToRGBDestFormatAndSize, so it does appear to be related.
Comment 7 Matthew Gregan [:kinetik] 2011-11-01 22:45:18 PDT
Created attachment 571245 [details] [diff] [review]
patch v0

Bug 630835 introduced this change: http://hg.mozilla.org/mozilla-central/diff/b8194445b364/layout/generic/nsVideoFrame.cpp

If I understand this correctly, it should be using frameSize rather than videoSize.
Comment 8 Matthew Gregan [:kinetik] 2011-11-01 22:46:23 PDT
*** Bug 640074 has been marked as a duplicate of this bug. ***
Comment 9 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-01 23:27:58 PDT
Comment on attachment 571245 [details] [diff] [review]
patch v0

Review of attachment 571245 [details] [diff] [review]:
-----------------------------------------------------------------

Right, we need to set the pre-transform size as the visible region.

Great! Let's get this into aurora and (if possible) beta!
Comment 10 Matthew Gregan [:kinetik] 2011-11-02 17:00:16 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/5e75c166fd2c
Comment 11 Marco Bonardo [::mak] 2011-11-03 08:50:31 PDT
https://hg.mozilla.org/mozilla-central/rev/5e75c166fd2c
Comment 12 Alex Keybl [:akeybl] 2011-11-07 13:47:50 PST
Comment on attachment 571245 [details] [diff] [review]
patch v0

[Triage Comment]
* We won't re-roll beta for this - only affects webm on Linux
* Approving for Aurora since we should have time to identify regressions as it progresses through the channels

Please land on Aurora today to make it in before the merge day tomorrow.
Comment 13 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-07 15:36:47 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/a0834921de1e

This could affect non-Linux platforms in theory. Not sure why it hasn't come up elsewhere.
Comment 14 Virgil Dicu [:virgil] [QA] 2011-11-09 00:34:46 PST
*** Bug 690356 has been marked as a duplicate of this bug. ***
Comment 15 Mihaela Velimiroviciu (:mihaelav) 2011-11-17 07:29:48 PST
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 6.1; rv:10.0a2) Gecko/20111116 Firefox/10.0a2
Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111116 Firefox/11.0a1

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111116 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111117 Firefox/11.0a1

Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a2) Gecko/20111117 Firefox/10.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111117 Firefox/11.0a1

Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 5.1; rv:10.0a2) Gecko/20111110 Firefox/10.0a2
Mozilla/5.0 (Windows NT 5.1; rv:11.0a1) Gecko/20111110 Firefox/11.0a1


Verified the fix on the above builds: described issue is no longer reproducible.

Note You need to log in before you can comment on or make changes to this bug.