If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Downloads Panel] New default indicator position and new behavior when invisible

RESOLVED DUPLICATE of bug 726444

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 726444
6 years ago
6 years ago

People

(Reporter: Paolo, Assigned: Paolo)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
| This bug describes changes to the version of the downloads panel and
| indicator that is currently present in the UX branch, more specifically:
| * Bug 564934, attachment 558500 [details] [diff] [review]
| * Bug 663772, attachment 558504 [details] [diff] [review]
| 
| Patches for this bug should apply on top of the two mentioned patches.

On new profiles and after migration from older versions, the downloads
indicator should be placed in the navigation bar (see UI mockup in the
bug's URL).

If the navigation bar is invisible, for example while displaying a toolbarless
app tab, the exact behavior is still to be defined. Interesting cases:

* A new download is started by clicking an item in the page.
* There are in-progress downloads started previously.
* An in-progress download just terminated.
* The user requested to display the panel using shortcuts or menu items.

The simplest solution is to never show the indicator and show the panel
without an anchor (and maybe no arrow) if explicitly requested. Other
solutions involve showing the anchor temporarily on another toolbar (if
available), which is currently implemented for the tab and navigation bars.
or don't show anything, unless the button is visible.
(Assignee)

Comment 2

6 years ago
(In reply to Marco Bonardo [:mak] from comment #1)
> or don't show anything, unless the button is visible.

Yes, though we lose all new download notifications! Where did my download go?

The most prominent case is when the navigation bar is hidden, for example I'm
downloading an attachment using an on-line mail application placed on an app tab.
(Assignee)

Comment 3

6 years ago
Created attachment 596010 [details] [diff] [review]
The patch

This simply moves the button from the tab bar to the navigation bar. The button
is still displayed temporarily as an anchor if needed.
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
(Assignee)

Comment 4

6 years ago
The patch on this bug is now included as part of the patch in bug 726444. Any
pending issue here should have already been filed as one of the bug's follow-ups.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726444
You need to log in before you can comment on or make changes to this bug.